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ВВЕДЕНИЕ

Данное руководство предназначено для пользователей, которые переходят с OrCAD/Allegro PCB Designer на Altium 
Designer. Даже если вы впервые открыли Altium Designer и еще не знакомы с тонкостями работы в этой САПР, то 
данное руководство значительно ускорит освоение базовых возможностей программы в максимально сжатые 
сроки. Оно написано экспертами, отлично владеющими функционалом OrCAD/Allegro PCB Designer и Altium Design-
er и много лет посвятившими изучению этих популярных САПР. Ориентируясь на ваш опыт работы с системами 
проектирования от Cadence вы без труда сможете перейти на систему Altium Designer, которая имеет неоспоримые 
преимущества перед другими аналогичными продуктами.

Руководство построено так, чтобы вы смогли сравнить OrCAD и Altium на всех этапах маршрута разработки – 
от создания проекта и библиотек до подготовки файлов для производства. В руководстве будут рассмотрены 
следующие темы:

�� Интерфейс Altium Designer

�� Основные настройки

�� Создание библиотек компонентов

�� Создание библиотеки посадочных мест

�� Компиляция интегрированной библиотеки

�� Схема электрическая принципиальная

�� Постобработка схемы

�� Подготовка шаблона печатной платы

�� Размещение и трассировка

�� Проверка правил проектирования

�� Подготовка данных для производства

В каждом разделе будут рассмотрены соответствующие инструменты Altium Designer и OrCAD PCB Designer 
совместно. Естественно, будут освещены такие вопросы как подготовка Bill of Materials, Annotation, Search and Naviga-
tion и другие.

Основное преимущество Altium Designer перед другими системами проектирования – это единая среда 
проектирования, единая программная оболочка, в которой запускаются все необходимые вам редакторы. В 
программе реализован общий подход к управлению объектами схемы и топологии. Это принципиальное отличие 
от других систем проектирования, таких как Cadence OrCAD/Allegro и Mentor PADS, помогает быстро освоить 
инструменты Altium Designer, перейдя к практической работе. Благодаря наличию таких удобных универсальных 
элементов управления, как панель инструментов Active Bar или панель Properties, реализованных в схемном и 
топологическом редакторах, Altium Designer является невероятно удобной и интуитивно понятной САПР.

На сегодняшний день Altium Designer – единственная САПР, доступная по стоимости организациям любого уровня, 
а также индивидуальным разработчикам, в которой есть весь необходимый функционал для работы над проектами 
различной степени сложности. Даже если вы работали долгое время в других САПР, то вы сможете без труда 
транслировать ваши наработки в Altium Designer, благодаря наличию превосходных встроенных в Altium Designer 
трансляторов. Кроме этого, система отлично интегрируется в маршрут разработки электромеханических проектов 
в единой связке с MCAD-системами. Мощная 3D-среда в Altium Designer обладает высокой производительностью 
и высококачественным рендерингом. Вы можете создавать даже многоплатные проекты, где несколько проектов 
печатных плат электрически связаны между собой.

Итак, давайте начнем. В добрый путь!

http://www.altium.com/ru
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Вы можете нажать на вкладку активного документа правой кнопкой мыши (ПКМ) и выбрать команду Split Verti-
cal из контекстного меню для отображения данного документа в отдельном окне. Это же контекстное меню меню 
позволяет вам вернуться к однооконному режиму при помощи команды Merge All.

Ваш проект Demoj загружен и вся его структура теперь отображается на панели Projects с новым расширением 
*.PrjPcb. В структуре проекта откройте папку Libraries\Schematic Library Documents и откройте библиотеку 
Demoj_Library.SchLib. После этого справа внизу будет доступна вкладка панели Sch Library. Нажмите на нее, чтобы 
просмотреть структуру транслированной библиотеки проекта. Эта библиотека была создана автоматически из 
всех компонентов, которые сейчас размещены у вас на схеме. Она также доступна на панели Libraries. Вы можете 
развернуть эту панель как это показано на Рис. 1.1 выше, и выбрать ее из выпадающего списка вверху панели 
Libraries. Библиотека необязательно должна входить в состав проекта.

Рис. 1.1 - Интерфейс Altium Designer

1. РЕДАКТОРЫ И ИНТЕРФЕЙСЫ

Единый интерфейс и Приложения

Altium Designer –  это единая универсальная программная оболочка, под управлением которой запускаются все 
редакторы. Это не мешает вам работать с несколькими мониторами и, к примеру, переносить на отдельный монитор 
редактор топологии (просто перенесите вкладку документа на соседний монитор). Основу системы управления в 
программе составляют всевозможные панели, которые легко активируются кнопкой Panels в правом нижнем углу 
окна на строке состояния. Главными из них являются панель Projects, Libraries. Рабочие панели могут быть в открытом 
состоянии, как например, Projects на Рис. 1, и в свернутом, как например, Libraries. Вы можете свободно перемещать 
панели с одного края окна на другой. Кроме того, в верхней части редакторов присутствует так называемая панель 
инструментов Active Bar, на которой представлены кнопки для наиболее часто используемых команд.

Если вы делаете двойной щелчок мышью по документу в панели Projects, например, листу схемы, то этот документ 
появляется на экране, а его вкладка отображается над самим документом. Можно открыть много документов и 
переключаться между ними при помощи горячих клавиш Ctrl+Tab или просто щелкая по вкладкам (Рис. 1.1).
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OrCAD Capture имеет традиционный интерфейс, где все команды запускаются либо из основного меню, либо с 
панелей инструментов. Для работы с библиотеками открывается панель Place Part. Однако набор рабочих панелей 
здесь ограничен и, например, все свойства отдельных элементов дизайна, цепей, компонентов, символов питания и 
заземления и других, редактируются через специальный Property Editor. В Altium Designer свойства указанных выше 
элементов редактируются через специальную панель Properties, что более удобно.

OrCAD PCB Designer

Как вы видели, в организации двух систем Altium Designer и OrCAD PCB Designer есть серьезные отличия. OrCAD – это 
набор разных приложений, которые запускаются через меню Пуск или при передаче нетлиста, как это происходит в 
случае с OrCAD PCB Editor. OrCAD Capture совершенно не похож по своей идеологии и системе управления на OrCAD 
PCB Editor – это абсолютно разные приложения, между которыми мало общего.

В OrCAD Capture также есть свой Project Manager, но на нем отображаются далеко не все файлы, входящие в проект 
(Рис. 1.2).

Рис. 1.2 - Интерфейс OrCAD Capture

http://www.altium.com/ru
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Рис. 2.1 - Маршрут разработки в OrCAD PCB Designer

Передача данных между OrCAD Capture и OrCAD PCB Designer происходит строго на основе текстового нетлиста, 
состоящего из трех файлов pst*.dat. Все свойства компонентов и цепей, правила разработки, информация о классах 
и комнатах также передаются посредством нетлиста с учетом специального файла конфигурации allegro.cfg.

Altium Designer предлагает более оптимизированный и структурированный подход – создается проект печатной 
платы на основе главного файла проекта, который объединяет в себе все входящие документы – листы схем, файлы 
топологии (возможно включить в проект несколько файлов), файлы библиотек и т.д. Во время процесса ECO все 
изменения, включая классы, комнаты, правила разработки и т.д., выводятся в специальном окне, где пользователь 
может отклонить или оставить любое из передаваемых изменений. Вы можете достаточно тонко настроить процесс 
ECO через опции проекта. Кроме этого, дополнительно в состав Altium входит технологический модуль CAMtastic для 
просмотра и обработки выходных файлов для производства (Рис. 2.2).

2. МАРШРУТ ПРОЕКТИРОВАНИЯ 

В этой части мы рассмотрим маршрут проектирования в Altium Designer. В целом он не сильно отличается от маршрута 
OrCAD PCB Designer, но в целом представляет собой более организованное решение.

Маршрут разработки печатной платы, к которому вы привыкли в OrCAD PCB Designer, по сути, состоит в работе с 
двумя основными приложениями – OrCAD Capture для создания компонентов и схем и OrCAD PCB Editor для создания 
посадочных мест и топологии. В расширенном варианте сюда может входить моделирование электрических схем в Or-
CAD PSpice, анализ целостности сигналов в OrCAD Signal Explorer (OrCAD PCB SI), подготовка проектов ПЛИС в OrCAD FPGA 
System Planner, а также автоматическая трассировка в SPECCTRA (Allegro PCB Router) (Рис. 2.1).

http://www.altium.com/ru
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Рис. 2.2 - Маршрут разработки в Altium Designer
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На панели Project Manager не отображаются данные по файлам топологии (*.brd) и различного типа библиотекам 
(*.psm, *.bsm, *.ssm и т.д.). OrCAD PCB Editor. В этом как вы увидите дальше кроется принципиальное различие 
между двумя системами. OrCAD в своей файловой структуре здесь выглядит более архаичной и в чем-то 
разрозненной системой, что обусловлено ее историей развития.

Проект Altium Designer в самом простом случае может состоять из трех типов файлов:

�� *.PrjPcb – заглавный файл проекта печатной платы

�� *.SchDoc – файл листа схемы

�� *.PcbDoc – файл топологии платы

Рис. 3.1 - Структура проекта на панели Project Manager в OrCAD Capture  
и типовая структура директорий проекта OrCAD PCB Designer

3. ФАЙЛОВАЯ СТРУКТУРА ПРОЕКТОВ

В этой части мы рассмотрим то, как выглядит структура проекта и входящие в него файлы в Altium Designer. Здесь есть 
ряд особенностей в сравнении с OrCAD PCB Designer, например, наличие отдельного файла для каждого листа схемы, 
единый файл проекта и т.д.

Как вы знаете и как это уже отмечалось выше OrCAD это набор разных по своему характеру приложений. Это также 
хорошо прослеживается по файловой структуре. На панели Project Manager отображается только схемотехническая 
часть проекта. Это прежде всего файл схемы *.dsn, куда входят все листы и вся иерархическая структура, библиотеки 
компонентов *.olb и ряд других файлов, которые выводятся на панель Project Manager в OrCAD Capture (Рис. 3.1).

http://www.altium.com/ru
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Еще одно принципиальное отличие – каждый лист схемы в Altium Designer является отдельным файлом. Это сделано 
для удобства управления файлами, контроля истории изменений и возможности восстановления каждого файла 
проекта по-отдельности. Вы можете видеть, что в папке с проектом также формируются директории для выходных 
файлов, для логов и специальная папка History, откуда можно восстанавливать сохраненные копии документов.

Вы можете перетаскивать файлы между проектами на панели Projects. Файлы, находящиеся за пределами 
директории с проектом, но входящие в его состав, отображаются в виде ярлыка, со стрелкой на иконке. 

В Altium Designer создать новый проект можно в диалоговом окне PCB Project, которое можно открыть с помощью 
команды File » New » Project » PCB Project. После создания проект также появится на панели Projects как пустой файл 
c расширением *.PrjPcb.

Именно с создания нового главного файла проекта *.PrjPcb начинается разработка печатной платы в Altium De-
signer. О проекте печатной платы в Altium Designer необходимо знать следующую начальную информацию:

Рис. 3.2 - Панель Project и типовая структура директорий проекта Altium Designer

Аналогично OrCAD PCB Designer для управления файлами проекта в Altium Designer существует специальная 
панель – Projects. Однако, в отличие от OrCAD, здесь отображаются все файлы, входящие в проект, включая файлы 
библиотек, выходные файлы для производства и даже файлы других программ, например, BOM файл в формате 
Excel и т.д. Структура директорий проекта также напоминает OrCAD (Рис. 3.2). 

http://www.altium.com/ru


www.altium.com/ru 12

РУКОВОДСТВО ПО ПЕРЕХОДУ C CADENCE OrCAD®

После создания нового файла пересохраняйте его в папке с проектом, как об этом было упомянуто выше.

Обратите внимание, если вы не можете быстро найти нужный документ, компонент, цепь и т.д., то воспользуйтесь 
строкой поиска Search на панели Projects. Это значительно ускорит вашу работу.

1.	 Заглавный файл проекта *.PrjPcb содержит только настройки и ссылки на все входящие в него документы – 
листы схемы (*.SchDoc), файл топологии (*.PcbDoc), библиотеки компонентов (*.SchLib) и т.д.

2.	 Каждый лист схемы – это отдельный файл с расширением *.SchDoc.

3.	 Все файлы одного проекта должны храниться в одной директории с заглавным файлом. Это упростит всю 
дальнейшую работу.

4.	 На панели Projects отображается статус каждого документа и проекта в целом:     – есть изменения,   – 
документ открыт.

5.	 Для закрытия всего проекта необходимо нажать по заглавному файлу ПКМ и выбрать команду Close Project из 
контекстного меню. В этом меню вы также найдете команду для закрытия всех документов.

6.	 Для удаления документов из проекта достаточно перетащить их на пустое поле на панели Projects или нажать 
ПКМ и выбрать команду Remove from Project контекстного меню.

7.	 Все документы, не входящие в проект, отображаются как Free Documents.

Вы можете добавлять новые файлы в проект командой Add New To Project контекстного меню заглавного файла 
проекта (Рис. 3.3).

Рис. 3.3 - Создание нового файла в рамках проекта печатной платы
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4. НАСТРОЙКА СРЕДЫ ПРОЕКТИРОВАНИЯ

В этом разделе мы рассмотрим основные настройки схемотехнического редактора Altium Designer, в том числе 
настройки для текущих документов, а также применение шаблонов оформления чертежей схемы. 

Основные настройки схемотехнического редактора

В схемотехническом редакторе OrCAD Capture вы 
выполняете все базовые настройки перед созданием 
нового проекта в диалоговом окне Design Template, 
открываемом с помощью команды Options » Design 
Template главного меню. Здесь на вкладке Page Size 
выбираются единицы измерения, шаг сетки, который 
определяется параметром Pin-to-Pin Spacing и размер 
листа (Рис. 4.1).

Стиль и цвет сетки определяется в диалоговом окне 
Preferences (Options » Preferences) на вкладках Grid 
Display и Color/Prints соответственно.

Все редакторы в Altium Designer настраиваются через 
единое диалоговое окно Preferences, доступ к которому 
можно получить в верхнем правом углу редактора или 
при нажатии ПКМ в области документа (Рис. 4.2).

В разделе Schematic вы найдете все настройки для 
схемотехнического редактора. Для настройки единиц 
измерения перейдите на страницу Schematic - General 
(Рис. 4.3).

Рис. 4.1 - Настройка единиц измерения и шага сетки в OrCAD Capture

Рис. 4.2 - Переход к настройкам Altium Designer

Рис. 4.3 - Установка единиц измерения в Altium Designer
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Для настройки сетки необходимо перейти на страницу Schematic - Grids. Здесь, в отличие от OrCAD Capture, вы 
определяете сразу все параметры – стиль, цвет и шаг сетки (Рис. 4.4).

Как вы можете видеть, сетка здесь условно делится на три составляющие – сетку привязки, расстояние привязки и 
видимую сетку. Рекомендуется для всех трех сеток устанавливать одинаковые значения, чтобы не путаться при работе 
над схемой и библиотекой компонентов. Для добавления дополнительного шага просто нажмите ПКМ и выберите 
значение из подменю Add GridSetting. Вы также можете вручную изменять значения шага.

Шрифты для всех элементов схемы в OrCAD Capture настраиваются в том же диалоговом окне Design Template (Options » 
Design Template) на вкладке Fonts, где вы можете задать шрифты для всех элементов, таких как Part Reference, Text, Pin 
Name, Pin Number и других (Рис. 4.5).

Рис. 4.4 - Настройка сетки в Altium Designer

Рис. 4.5 - Окно настройки шрифтов в OrCAD Capture
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Цвет различных объектов в OrCAD Capture настраивается в диалоговом окне Preferences (Options » Preferences) на 
вкладке Color/Prints.

В Altium Designer вы можете перейти на страницу Schematic - Defaults диалогового окна Preferences и здесь, выбрав 
соответствующие единицы измерения, задать шрифты и цвет для всех элементов схемы, подобно тому, как это делается 
в OrCAD. Например, для задания позиционным обозначениям нужного шрифта и цвета просто выберите объект Desig-
nator, и настройки его шрифта отобразятся справа от списка объектов (Рис. 4.6).

Рис. 4.6 - Настройка цвета и шрифта для объектов в Altium Designer

Рис. 4.7 - Основные настройки для текущего листа схемы в Altium Designer

Основные настройки текущих листов схемы 

В OrCAD Capture настройки для текущих листов схемы, такие как размер листа и единицы измерения вы можете 
изменить в диалоговом окне Schematic Page Properties (Options » Schematic Page Properties). Эти настройки от 
рассмотренных выше отличаются только тем, что невозможно для уже созданного проекта поменять основной шаг 
сетки. Вы можете задать шаг сетки, кратный текущему, в диалоговом окне Preferences на вкладке Grid Display через 
параметр Grid Spacing.

В Altium Designer поменять настройки для текущих листов вы можете через панель Properties в режиме Document 
Options (активен, когда в рабочей области нет выделенных объектов). На этой панели доступны настройки единиц 
измерения, сетки, размера листа и т.д.. Также поменять шаг сетки вы можете при помощи клавиши G (Рис. 4.7).
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Настройка шаблонов оформления листов схемы

Перед началом работы в OrCAD Capture вы можете настроить размер листа и его шаблон по умолчанию. Для 
заполнения основной надписи используются настройки на вкладке Title Block диалогового окна Design Template. 
Здесь вы заполняете основные текстовые параметры, такие как автор документа, его номер и другие. Изменение 
положения основной надписи происходит автоматически с изменением размера листа. Если у вас возникает 
необходимость изменить форматку, то это можно сделать по команде меню Place » Title Block. При этом вы 
выбираете элементы оформления листа из встроенной библиотеки capsym.olb или из любой вашей библиотеки, 
где такие форматки присутствуют.

В Altium Designer форматку по умолчанию можно задать через параметр Template страницы Schematic - General 
диалогового окна Preferences (Рис. 4.8).

Поменять ее для текущего листа можно при помощи все той же панели Properties в режиме Document Options, в 
разделе Page Options (Рис. 4.9).

Также замена шаблонов возможна через группу команд меню Design » Templates.

Заполнение основной надписи происходит через панель Properties на вкладке Parameters. При создании форматки 
также, как и в OrCAD, здесь в Altium Designer используются параметры документов, которые могут принимать любые 
значения. Именно их значения вы можете изменить на вкладке Parameters.

Рис. 4.8 - Выбор форматки по умолчанию для новых листов схемы в Altium Designer

Рис. 4.9 - Изменение форматки для текущего листа схемы через панель Properties
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5. КОНЦЕПЦИЯ БИБЛИОТЕК 

Данный раздел содержит описание концепции библиотек Altium Designer, а также их сравнение их с концепцией 
библиотек OrCAD.

Оффлайн библиотеки

Система OrCAD содержит большое количество базовых библиотек, которые поставляются в комплекте с 
программой и могут быть использованы как для разработки топологии, так и для моделирования электрических 
схем при помощи PSpice. Это схемотехнические библиотеки с расширением *.olb, например, библиотека 
дискретных устройств Discrete.olb, библиотека микроконтроллеров Microcontroller.olb, библиотека 
операционных усилителей OPAmp.olb и другие. Библиотеки Spice моделей также достаточно обширны и имеют 
расширение *.lib. Например, библиотека биполярных транзисторов bjn.lib, диодов Шоттки chottky.lib и 
другие (Рис. 5.1). 

Рис. 5.1 - Библиотеки OrCAD Capture

Библиотеки посадочных мест в базовом комплекте OrCAD представлены в виде файлов *.psm и парных им *.dra 
файлов, где каждая пара psm и dra – это отдельное посадочное место. Также отдельными файлами представлены 
библиотеки падстеков с расширением *.pad. Для нестандартных форм выводов возможно создание Shape 
символов c расширением *.ssm с последующей интеграцией в pad (Рис. 5.2).
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Рис. 5.2 - Структура библиотек PCB Editor

Интегрированных библиотек в OrCAD нет, а подключение символов схемы и платы происходит на уровне свойств 
компонентов. Вы можете присвоить посадочное место просто внеся его название в значение свойства PCB Foot-
print как на уровне библиотеки, так и на уровне схемы.

Вы можете скачивать библиотеки для OrCAD с сайтов производителей. Отдельного ресурса, где существует готовая 
БД компонентов для OrCAD, нет.

Как показано на Рис. 5.2, вы также можете использовать систему OrCAD CIS для параметрического поиска, 
верификации и добавления размещения компонентов в проекте с применением драйвера ODBC, что позволяет 
интегрировать OrCAD с корпоративной системой документооборота.

Altium Designer предлагает несколько типов файловых библиотек. Стандартные библиотеки компонентов с 
расширением *.SchLib имеют тот же смысл, что и *.olb в OrCAD. Вы можете использовать их при создании 
схемы. Принципиально отличаются библиотеки посадочных мест, которые имеют расширение *.PcbLib. В одном 
файле *.PcbLib может содержаться множество посадочных мест. Вы можете объединить библиотеки *.SchLib 
и *.PcbLib в одну интегрированную библиотеку *.IntLib. Дополнительно вы можете использовать систему CIS 
по аналогии с OrCAD. В Altium это называется библиотекой базы данных компонентов DbLib, которая может 
быть построена на основе файла описания Excel, Access, SQL и других табличных систем и систем управления БД. 
Подключение БД в Altium производится на основе стандартного интерфейса ODBC. Также вы можете использовать 
библиотеки *.CmpLib, предназначенные для использования в рамках системы Altium Vault (Рис. 5.3).
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Онлайн библиотеки

OrCAD PCB Designer не содержит как таковой онлайн библиотеки, которую можно подключить через встроенную 
рабочую панель. Вы можете скачивать готовые библиотеки с сайтов производителей компонентов или через 
платный модуль Ultra Librarian.

Altium предлагает своим пользователям помимо оффлайн библиотек также доступ к глобальной библиотеке 
Altium Content Vault. Это ресурс, который доступен всем лицензионным пользователям Altium содержит большое 
количество готовых библиотек компонентов с параметрической информацией для быстрого поиска и создания 
документации. Доступ к библиотеке осуществляется непосредственно из схемотехнического редактора Altium De-
signer при помощи панели Explorer (Рис. 5.4).

Рис. 5.3 - Библиотеки Altium Designer
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Вы можете формировать ваши собственные библиотеки на основе компонентов Vault и использовать их совместно 
со стандартными библиотеками SchLib, IntLib, DbLib.

Рис. 5.4 - Панель Explorer c данными глобальной библиотеки Altium Content Vault
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6.  ПОИСК И ДОБАВЛЕНИЕ КОМПОНЕНТОВ В ПРОЕКТ

В данном разделе будут рассмотрены инструменты поиска и добавления компонентов на схему в Altium Designer и 
проведена аналогия с OrCAD Capture.

Панель библиотек и поиск компонентов

OrCAD Capture содержит несколько способов размещения компонентов на схему. Самый простой это панель Place 
Part (вызывается кнопкой P). Здесь вы можете подключить нужную вам библиотеку и выбрать компонент для 
размещения на схеме (Рис. 6.1).

Рис. 6.1 - Панель Place Part в OrCAD Capture
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На данной панели вы также можете воспользоваться поиском в секции Search For Part. В качестве критерия поиска 
может выступать только название компонента в библиотеке.

Основной панелью для поиска и размещения компонентов на схему в Altium Designer является панель Librar-
ies. Данная панель по умолчанию находится  в свернутом состоянии в правой части окна редактора. Если она 
отсутствует, то просто активируйте ее при помощи кнопки Panels в правом нижнем углу окна программы. При 
помощи кнопки Libraries в верхней части панели вы можете подключить библиотеки компонентов, включая 
библиотеку базы данных, библиотеку Vault и другие. При помощи кнопки Search осуществляется поиск компонентов 
по заданным директориям на основе критериев пользователя (название, производитель, номер и т.д.) (Рис. 6.2):

По умолчанию все стандартные библиотеки располагаются в директории C:\Users\Public\Documents\Altium\
AD18\Library. Если вам необходимо подключить дополнительные библиотеки, то просто нажмите на кнопку Librar-
ies. Здесь на вкладке Project отображается список библиотек, которые входят в состав текущего проекта. На вкладке 
Installed в нижней части окна в строке Library Path Relative To указывается общая директория с библиотеками. Если 
необходимо подключить библиотеки из других директорий, то необходимо нажать на кнопку Install » Install From 
file/Vault.

На панели Libraries в верхнем выпадающем списке вы выбираете одну из подключенных библиотек, в следующей 
строке вводите маску названия, чтобы ускорить поиск по имеющимся компонентам в выбранной библиотеке.

Рис. 6.2 - Панель Libraries
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Размещение компонентов

После выбора нужного компонента в OrCAD Capture на панели Place Part вы делаете двойной клик и компонент 
перемещается на схему. Для стандартных действий доступны следующие клавиши: R – поворот, H/V – зеркальное 
отображение по горизонтали и вертикали. Сочетание Ctrl+E позволяет в момент размещения перейти в окно 
базовых свойств. 

Вы можете размещать компоненты с включенной автоматической нумерацией. Программа будет отслеживать 
уже имеющие номера в проекте и присваивать вновь размещаемым компонентов номера по порядку. Можно 
отключить автонумерацию. Также доступна функция автоматической нумерации всех компонентов схемы.

В Altium Designer компонент размещается на схеме простым перетаскиванием его с панели Libraries или при 
помощи кнопки Place в верхней части панели. При размещении вы можете открыть список стандартных клавиш 
при помощи клавиши ~. Наиболее часто используемые кнопки – это Пробел (поворот компонента), X (зеркальное 
отображение по горизонтали), Y (зеркальное отображение по вертикали).

Altium Designer не содержит функции, при которой компонентам автоматически присваиваются номера при 
размещении их на схеме. Вы можете воспользоваться широкими возможностями автоматической нумерации 
компонентов.

Design Cache

Как вам известно все компоненты, которые попадают на схему в OrCAD хранятся в «директории» проекта, которая 
называется Design Cache. Вы можете при помощи Design Cache повторно использовать компоненты в рамках 
проекта, произвести замену компонента и его обновление. Вы также можете создать новую библиотеку *.olb и 
сохранить в нее все компоненты из Design Cache (Рис. 6.3).

Рис. 6.3 - Design Cache на панели Project Explorer в OrCAD Capture
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В Altium Designer нет Design Cache, но компоненты также хранятся в памяти схемной страницы. Вы точно также 
можете создать библиотеку проекта. Для этого достаточно использовать команду Design » Make Schematic Library/
Make Integrated Library. Для обновления и замены компонентов из библиотек предусмотрена отдельная команда 
Tools » Update From Libraries (Рис. 6.4).

Рис. 6.4 - Команды для создания библиотеки из проекта
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7. СОЗДАНИЕ СОЕДИНЕНИЙ

В данном разделе будут рассмотрены объекты электрических связей на схеме Altium Designer, свойствах цепей и 
области действия идентификаторов цепей в Altium Designer.

Типы соединений

 Altium Designer позволяет создавать аналогичные 
объекты различными способами, включая Active Bar и 
горячие клавиши (Рис. 7.2). 

OrCAD Capture позволяет создавать как одиночные 
цепи (Wire), так и линии групповой связи (BUS, Net 
Group) (Рис. 7.1). Все эти объекты можно найти в 
меню Place или воспользоваться клавишами W, B, U 
соответственно.

Есть небольшая разница в том, как описываются 
Net Group в OrCAD и Harness в Altium Designer – 
идентичные по своему предназначению линии 
групповой связи. Для создания Harness используется 
группа команд Place » Harness. Необходимо в первую 
очередь разместить Harness Connector, затем 
размещаются входные сигналы Harness Entry. Для 
соединения Harness размещается специальный тип 
линии Signal Harness (Рис. 7.3).

Рис. 7.1 - Типы соединений в OrCAD Capture

Рис. 7.2 - Типы соединений в Altium Designer

Рис. 7.3 - Объект Harness в Altium Designer
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Вы можете повторно использовать Harness по команде Place » Harness » Predefined Harness Connector. Описания 
Harness хранятся в текстовых файлах, которые можно найти в структуре проекта на панели Projects в разделе Set-
tings\Harness Definitions Files.

Свойства и параметры цепей

В Altium Designer на схеме можно поменять только 
ширину и цвет цепей через панель Properties. Никаких 
дополнительных параметров для цепей указать 
нельзя (Рис. 7.5). Если необходимо указать правило 
для топологии, то это делается через специальные 
директивы.

В OrCAD Capture вы можете присваивать различные 
свойства цепям, размещаемым на схеме. Например, 
в Property Editor вы можете указать свойство MIN_
LINE_WIDTH и тем самым определить минимальную 
ширину трасс для данной цепи. Любое из свойств 
может быть видимым. Вы также можете изменить 
толщину и цвет цепей на схеме (Рис. 7.4).

Рис. 7.4 - Пример свойств цепи в OrCAD Capture

Рис. 7.5 - Пример свойств цепи в Altium Designer
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Область действия идентификаторов цепей

В OrCAD Capture все подчинено строгой структуре межстраничных переходов. Вы можете поставить одинаковые 
метки цепей по команде Place » Net Label на разных листах схемы, но соединятся между собой они будут, если на их 
концах стоит межстраничный переход (Off-Sheet Connector) или порт (Port). В иерархических проектах соединения 
между главными и подчиненными схемами происходит только через порты.

В Altium Designer вы также можете использовать межстраничные переходы и порты. Однако, вы можете менять 
область действия идентификаторов цепей в диалоговом окне Project Options (Project » Project Options) на вкладке 
Options. Здесь для этого используется параметр Net Identifier Scope (Рис. 7.6). 

Рис. 7.6 - Изменение области действия меток цепей в опциях проекта Altium Designer

�� Automatic (на основе содержимого проекта) – этот режим автоматически выбирает, какой из режимов 
использовать основываясь следующими критериями: 

΃΃ при наличии листа верхнего уровня, используется Hierarchical;

΃΃ если листа верхнего уровня нет, но присутствуют порты, используется Flat;

΃΃ если листа верхнего уровня и портов нет, то используется Global.

�� Flat (глобальные только порты) – все порты с одинаковым наименованием будут подключены на всех листах в 
единую цепь, метки цепей являются локальными для каждого листа. Эта опция может быть использована для 
многолистовых проектов. Не рекомендуется для больших проектов, поскольку это может вызвать трудность 
отслеживания цепи на всех листах. 

�� Hierarchical (Лист <-> порты соединения, порты питания глобальные) – подключение по вертикали между 
портом и входом листа. Связь между листами осуществляется на листе верхнего уровня иерархии. Также порты 
питания являются глобальными – все порты питания с одинаковыми именами объединяются в одну цепь в 
пределах всего проекта. 

�� Strict Hierarchical (Лист <-> порты соединения, порты питания локальных) – работает аналогично режиму Hier-
archical, с той лишь разницей, что порты питания осуществляют локальную связь в пределах листа.

�� Global (метки цепей и порты глобальные) – одноименные метки цепей и порты объединяются в единую цепь 
на всех листах проекта. 
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8. ИЕРАРХИЯ И МНОГОКАНАЛЬНОСТЬ

В данном разделе будет рассказано о том, как создается иерархия и многоканальность в проектах Altium Designer. 
Также будет затронут вопрос синхронизации иерархических блоков и подчиненных листов схемы.

Создание иерархии

Создание иерархического проекта в OrCAD Capture вы можете вести традиционно в двух направлениях – сначала 
создается блок, а затем подчиненная схема («сверху-вниз») или вначале вы создаете схему, а затем представляете 
ее как иерархических блок на основной схеме («снизу -вверх»). Иерархический блок размещается по команде Place 
» Hierarchical Block. Затем на блоке размещаются выводы, Place » Hierarchical Pin. В свойствах блока необходимо 
указать название подсхемы, позиционное обозначение и тип (Рис. 8.1).

В Altium Designer иерархический блок называется Sheet Symbol, а вывод блока называется Sheet Entry. Размещаются 
они через меню Place. Все свойства блока и выводов можно определить через панель Properties. Вы можете 
использовать такую же методология работы с блоками, как и в OrCAD Capture. Точно также можно создать сначала 
схему, а потом блок и наоборот (Рис. 8.2). 

Рис. 8.1 - Иерархический блок и подчиненная схема в OrCAD Capture

Рис. 8.2 - Иерархический блок и подчиненная схема в Altium Designer
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Все команды для работы с Sheet Symbol  вы найдете в 
меню Design. Например, для преобразования блока в 
схемный лист используется команда Design » Create 
Sheet From Sheet Symbol. Обратная команда Design 
» Create Sheet Symbol From Sheet позволяет создать 
блок из листа схемы. При этом вы можете выбирать из 
какого листа будет создан блок (Рис. 8.3).

В OrCAD синхронизация схемы и блока по портам и 
выходам соответственно происходит при помощи 
меню ПКМ по команде Synchronize Up/Down (Рис. 8.4).

В Altium Designer для синхронизации вы используете 
команду Design » Synchronize Sheet Entries And Ports. 
В окне синхронизации будут отображаться вкладки для 
всех блоков и вы можете выбрать выводы и порты для 
синхронизации (Рис. 8.5).

Синхронизация блоков

Рис. 8.3 - Выбор листа схемы для создания блока в 
Altium Designer

Рис. 8.4 - Синхронизация схемы и иерархического блока в OrCAD

Рис. 8.5 - Синхронизация Sheet Symbol в Altium Designer
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Многоканальность

В OrCAD Capture вы можете создать копию блока на листе схемы тем самым обеспечить многоканальность (Рис. 8.6).

Если говорить о многоканальности, то в отличии от OrCAD Capture в Altium Designer вам нет необходимости 
копировать блок несколько раз на схеме. В Altium Designer принята следующая методология по работе с 
многоканальными блоками:

1.	 Вместо Reference Designator прописывается специальное слово Repeat с наименованием каналов и их 
номерами.

2.	 Каждый канал в итоге преобразуется в отдельную комнату на плате, где, после размещения и трассировки 
одной комнаты, вы сможете получить несколько одинаковых фрагментов топологии, скопированных по образцу 
(аналог Reuse Module).

Вот так выглядит многоканальный блок в Altium Designer после добавления в него директивы Repeat (Рис. 8.7).

Рис. 8.6 - Многоканальный иерархический блок в OrCAD Capture

Рис. 8.7 - Многоканальный иерархический блок в Altium Designer

http://www.altium.com/ru


www.altium.com/ru 31

РУКОВОДСТВО ПО ПЕРЕХОДУ C CADENCE OrCAD®

9. ПОИСК И НАВИГАЦИЯ НА СХЕМЕ

В этом разделе будут рассмотрены различные варианты поиска компонентов и цепей на схеме в Altium Designer.

Поиск по тексту

Результаты поиска отображаются на панели Find Window (Рис. 9.2).

Рис. 9.1 - Панель инструментов поиска в OrCAD Capture

Рис. 9.2 - Панель Find Window с результатами поиска

В OrCAD Capture вы можете нажать Ctrl+F и задать 
критерии поиска. В строке поиска вы вводите название 
цепи или любого другого объекта. Но при этом 
необходимо внимательно следить за тем откуда вы 
производите этот поиск и выбран ли соответствующий 
объект для поиска. Если поиск запускается на листе, 
то только в пределах этого листа возможно найти тот 
или иной объект. Для поиска по всему проекту следует 
сначала выбрать проект на панели Project Manager, а 
затем запустить поиск по соответствующим критериям 
(Рис. 9.1).
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В Altium Designer также достаточно нажать Ctrl+F для 
запуска стандартного инструмента поиска компонентов 
и цепей по тексту. Просто выберите по каким 
критериям и в какой части проекта вы хотите найти то 
или иной объект (Рис. 9.3).

Навигация по объектам

Если выбрать проект в Project Manager и перейти 
в меню Edit » Browse, то можно вывести список 
доступных в этом меню объектов с возможностью 
навигации (Рис. 9.5).

Инструментом навигации в OrCAD Capture также 
является панель Navigation Window, которая 
появляется если выбрать цепь и из меню ПКМ 
активировать Signals (Рис. 9.4).

Рис. 9.3 - Поиск компонента при помощи инструмента Find Text

Рис. 9.4 - Панель Navigation Window

Рис. 9.5 - Вызов навигации по объектам в OrCAD Capture
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Отличным инструментом для навигации в Altium 
Designer по схеме является панель Navigator. При 
помощи этой панели вы без труда найдете нужный 
компонент или цепь. Откройте панель, в верхней 
секции данной панели нажмите ПКМ – Compile All – в 
нижних секциях панели будет выведен список всех 
цепей и компонентов. Щелкая по каждому объекту, вы 
увидите его на экране крупным планом. Интересным 
представляется инструмент под названием Connec-
tivity Graph. Активируйте его из меню правой кнопки 
мыши, и программа при выборе цепи покажет точки 
подключения данной цепи на схеме (Рис. 9.6). Для 
отключения графа нажмите Ctrl+C.

Кнопка Interactive Navigation в верхней части панели 
Navigator позволяет вам выбирать цепи вручную на 
схеме и программа покажет их точки подключения. 
Вы также можете щелкнуть в режиме интерактивной 
навигации выводу иерархического блока или выбрать 
порт. В этом случае программа покажет ответную часть 
на соответствующем листе схемы.

Рис. 9.6 - Панель Navigator и граф соединений
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10. ПРОВЕРКА СХЕМЫ И УСТРАНЕНИЕ ОШИБОК

Здесь будет рассмотрена система контроля над ошибками на схеме в Altium Designer.

Набор правил проверки

Проверка ошибок, их поиск и устранение в OrCAD Capture возможна несколькими способами. Для настройки 
проверки используется диалоговое окно Design Rule Check (Tools » Design Rule Check). В этом диалоговом окне вы 
отмечаете тип ошибок, которые вы хотите проверять Run Electrical Rules и Run Physical Rules, на вкладках Electrical 
Rules и Physical Rules выбираете проверяемые правила (Рис. 10.1).

В OrCAD Capture принято два уровня ошибок: Warning 
и Error.

Среди прочих можно, например, отметить следующие 
ошибки:

�� Check duplicate net names – проверка 
дубликатов имен цепей

�� Check no driving source and Pin type 

conflicts – отсутствие источника сигнала и 
конфликт выводов

�� Check missing/illegal PCB Footprint Prop-

erty – проверка на отсутствие или неправильную 
запись свойства PCB Footprint

На вкладке ERC Matrix отображается матрица 
соединений, аналогично тому как это сделано в Altium 
Designer (Рис. 10.2).

Рис. 10.1 - Настройка правил проверки ошибок в OrCAD Capture

Рис. 10.2 - Матрица соединений в OrCAD Capture
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В Altium Designer для схемы процесс проверки правил проектирования осуществляется в рамках компиляции 
проекта. Все правила, на основе которых осуществляется проверка, содержатся в диалоговом окне Project Options 
(Project » Project Options) на вкладках Error Reporting и Connection Matrix. На вкладке Error Reporting все типы 
нарушений поделены на группы в соответствии с типом объектов, например, нарушения связанные с цепями или 
нарушения связанные с компонентами (Рис. 10.3).

Рис. 10.3 - Настройка проверок для схемы в Altium Designer

Рис. 10.4 - Вкладка Connection Matrix диалогового окна 
Project Options

Для каждого нарушения можно указать уровень его 
значимости – No Report, Warning, Error, Fa-
tal Error. Это позволяет устранить наиболее 
критически важные ошибки в проекте и игнорировать 
несущественные нарушения.

В качестве аналогов упомянутых выше проверок в 
OrCAD здесь можно привести следующие для Altium 
Designer:

�� Duplicate Nets – дублирование цепей

�� Net with no driving Source – цепь без 
источника сигнала

�� Missing Components Models – отсутствие 
посадочного места

На вкладке Connection Matrix пользователь выбирает 
уровень ошибок при подключении выводов 
различного типа на схеме (Рис. 10.4).
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Процесс проверки ошибок в Altium Designer 
запускается при выборе меню Project » Compile PCB 
Project <название_проекта>. В результате на экране 
появляется панель Messages, на которой отображается 
список ошибок и их подробное описание (Рис. 10.6).

Достаточно двойным щелчком выделить ошибку и 
на экране крупным планом будет показано место 
ее расположения. В секции Details отобразится 
подробное описание. Как правило, ошибки 
уровня Fatal Error и Error подчеркиваются 
волнистой линией. Вам достаточно навести курсор 
на место ошибки и ее описание будет выведено на 
всплывающей подсказке.

После устранения всех ошибок проведите повторную 
компиляцию, чтобы убедится в отсутствии ошибок.

После запуска проверки схемы на наличие ошибок в 
OrCAD Capture на схеме в местах ошибок появляются 
специальные маркеры в виде зеленых окружностей. 
Для навигации по маркерам используется меню Edit » 
Browse » DRC Markers или специальная команда File 
» Check and Save, после которой запускается панель 
Online DRCs с вкладками Warning и Errors. По двойному 
щелчку вы можете проводить навигацию по ошибкам 
во всем проекте (Рис. 10.5).

Поиск и выделение ошибок

Рис. 10.5 - Поиск ошибок через панель Online DRCs в OrCAD Capture

Рис. 10.6 - Список ошибок на панели Messages
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11. ПОДГОТОВКА BILL OF MATERIALS

Здесь рассматривается вопрос подготовки отчета Bill of Materials (BOM), а также новый подход к его формированию в 
Altium Designer при помощи инструмента ActiveBOM.

Выбор свойств и шаблонов

Если у вас имеется опция CIS и подключена БД, на 
основе которой была создана схема, то вы можете 
использовать дополнительный способ генерации BOM 
из диалогового окна Standard Bill of Materials (Reports 
» CIS Bill of Materials » Standard). Здесь из столбца 
Select Properties вы выбираете свойство и переносите 
его в правый столбец Output Format, формируя тем 
самым список атрибутов, которые должны выводится 
в BOM. Здесь вы можете использовать как атрибуты 
компонентов на схеме, так и атрибуты компонентов 
из БД CIS, при условии, что она подключена и 
соответствует компонентам схемы (Рис. 11.2).

Для формирования BOM в OrCAD Capture вы можете 
задействовать стандартный способ Tools » Bill of Mate-
rials (Рис. 11.1).

Здесь вы указываете заголовки атрибутов  в строке 
Header и сами атрибуты, которые должны считываться 
у компонентов схемы, в строке Combined property 
string. Вы можете использовать генерацию в формате 
Excel.

Как вы видите это разительно отличается от того, что 
предлагает вам Altium Designer. Создание BOM в OrCAD 
Capture классическим способом возможно только по 
одному встроенному шаблону.

Fig. 11.1 - BOM generating in OrCAD Capture

Рис. 11.2 - Создание BOM при помощи опции CIS в OrCAD Capture
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Дополнительным способом в OrCAD Capture служит генерация BOM на основе шаблонов Crystal Report. В программу 
встроены некоторые базовые шаблоны, но для создания новых вам необходима лицензия на Crystal Report или 
можно использовать бесплатную альтернативу, где поддерживается формат Crystal Report. Для работы с этим типов 
отчетов в OrCAD Capture используется диалоговое окно Crystal Reports Bill of Materials (Reports » CIS Bill of Materials » 
Crystal Reports).

Генерация BOM в Altium Designer происходит через диалоговое окно Bill of Materials (Reports » Bill of Materials). 
Здесь необходимо определить атрибуты компонентов, которые должны войти в BOM, задать формат и шаблон. 
Все атрибуты отлично транслируются со схемы OrCAD Capture, и их можно включить в BOM файл. Просто выберите 
их в разделе All Columns и поставьте напротив нужного атрибута метку в столбце Show. Отмеченные атрибуты 
отобразятся в основной таблице Bill of Materials. В разделе Export Options выберите формат выходного файла. 
Опции Add to Project и Open Exported позволяют добавить файл BOM непосредственно в структуру проекта и 
открыть после генерации соответственно. В секции Excel Options выберите подходящий шаблон Excel из папки с 
шаблонами (по умолчанию директория C:\Users\Public\Documents\Altium\AD18\Templates). Кнопка Export в 
левом нижнем углу окна Bill of Materials позволяет сгенерировать BOM (Рис. 11.3).

ActiveBOM

Одним из наиболее интересных и эффективных инструментов в Altium Designer является ActiveBOM. Это 
специальный тип документа с расширением .BomDoc, который вы можете добавить в проект стандартным способом, 
например, через меню File » New » ActiveBOM Document. Это интерактивный перечень элементов и одновременно 
спецификация для вашего проекта, который способен взаимодействовать с каталогами поставщиков через 
Интернет. БД поставщиков, такие как Farnell, Digi-Key, Future Electronics и других содержат каталоги на миллионы 
позиций с актуальной параметрической информацией и стоимостью. ActiveBOM в автоматическом режиме 
позволяет вам загрузить все ключевые атрибуты компонентов, которые необходимы для перечня и спецификации, 
а также подобрать оптимальную стоимость и поставщика. Кроме этого, ActiveBOM проверит текущие атрибуты 
компонентов на схеме на правильность заполнения, покажет какие компоненты имеют истекший срок годности или 
позиции, по которым нельзя найти поставщика.

Рис. 11.3 - Окно настройки и генерации Bill of Materials в Altium Designer
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Для автоматического поиска информации о 
компонентах вашего проекта на панели Properties 
в секции Solutions нажмите на кнопку Manufactur-
er Link – Edit. В окне Define Manufacturer Link Fields 
укажите название параметра, который отвечает за 
производителя и за номер компонента производителя 
(Рис. 11.4).

Далее просто нажмите кнопку Refresh над списком 
компонентов и через некоторое время в нижней части 
окна ActiveBOM появятся все решения для каждого 
компонента, если они имеются (Рис. 11.5).

Обратите внимание на секцию BOM Checks в нижней 
части панели Properties, где вы сможете настроить 
проверку и увидеть ошибки для вашего BOM. Напротив 
каждой позиции BOM отражается ее статус по итогам 
проверки (Рис. 11.6).

Об этом инструменте можно долго рассказывать, но в 
рамках нашего руководства по переходу ограничимся 
данной первичной информацией, которая дает 
представление об этом замечательном инструменте. 
Сгенерировать выходной BOM вы также как и в 
предыдущем описанном способе можете через меню 
Reports » Bill of Materials, запуская эту команду в 
режиме работы с ActiveBOM. 

Рис. 11.4 - Выбор ключевых параметров компонентов на 
панели Properties при работе с ActiveBOM

Рис. 11.5 - Окно ActiveBom после загрузки решений для 
компонентов

Рис. 11.6 - Проверка BOM на наличие ошибок
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12. БАЗОВЫЕ НАСТРОЙКИ РЕДАКТОРА ТОПОЛОГИИ

Здесь будут рассмотрены настройки системы единиц, шага сетки, точки начала координат и цветовой палитры.

Настройка системы единиц и шага сетки 

Шаг сетки можно настроить в это же диалоговом 
окне на вкладке Display через кнопку Grids или через 
меню Setup » Grids. В диалоговом окне настройки 
сетки вы можете задать сетку для каждого слоя по 
отдельности или для всех сразу. Существует две сетки 
Etch и Non-Etch – для всех сигнальных слоев и для всех 
несигнальных соответственно (Рис. 12.2).

В OrCAD PCB Editor система единиц настраивается в 
диалоговом окне Design Parameters Editor (Setup » Design 
Parameters), на вкладке Design. Здесь же вы можете 
настроить точность проекта, размер рабочего поля и 
другие параметры (Рис. 12.1).

Рис. 12.1 - Настройки системы единиц в OrCAD PCB Editor

Рис. 12.2 - Настройка сетки в OrCAD PCB Editor
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Настройка единиц измерения и шага сетки в Altium Designer происходит через панель Properties в режиме Board 
(который активен, когда в рабочей области нет выделенных объектов) в секции Grid Manager (Рис. 12.3).

Вы можете оставить в Grid Manager только глобальную сетку и изменять ее шаг при помощи клавиши G. 
Дополнительно при помощи кнопки Add можно добавить дополнительную прямоугольную или полярную сетку. 
Можно менять область действия сетки, например, использовать ее только для размещения компонентов.

Рис. 12.3 - Настройка шага сетки в Altium Designer на панели Properties

Рис. 12.4 - Вид и настройка точки начала координат в OrCAD PCB Editor

Точка начала координат

В OrCAD PCB Editor точку начала координат можно переместить по команде Setup » Change Drawing Origin. Вы 
можете отключить отображение данной точки через диалоговое окно Design Parameter Editor (Setup » Design Param-
eters), опция Display Origin на вкладке Display. Также в настройках Display – Color/Visibility – Drawing Format можно 
поменять цвет и отключить соответствующий слой Drawing_Origin (Рис. 12.4).
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В Altium Designer вы также можете перенести точку Origin при помощи команды меню Edit » Origin » Set. Команда 
Reset в этом меню позволяет перенести Origin в положение по умолчанию. Изменение видимости и цвета Origin 
возможно через панель View Configuration (Рис. 12.5).

Контроль цвета и видимости объектов и слоев

В OrCAD контроль видимости и цветовых настроек можно вести через диалоговое окно Color Dialog (Display » Color/Visibil-
ity). Здесь в категории Display вы может настроить системные цвета, например, Background, Via, Grids и т.д. (Рис. 12.6).

Рис. 12.5 - Вид и настройка начала координат в Altium Designer

Рис. 12.6 - Окно настройки системных цветов в OrCAD PCB Editor
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Помимо этого для пользователей доступна панель Visibility, где можно быстро поменять цвет и видимость для 
сигнальных слоев и слоев Plane. В выпадающем списке Views можно выбрать сочетания видимых слоев, которые в 
данный момент необходимы пользователю (Рис. 12.7).

Altium Designer помимо панели View Configuration, где вы можете управлять системными цветами и цветами слоев, 
также позволяет вам оперативно менять цвета при помощи ленты слоев, расположенной под изображением платы. 
Просто нажмите ПКМ и выберите интересующее вас команду (Рис. 12.8).

Рис. 12.7 - Панель Visibility в OrCAD PCB Editor

Рис. 12.8 - Изменение цвета и видимости слоев в Altium Designer
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Вы также можете переходить в режим отображения одного слоя при помощи клавиш Shift+S. В это режиме вы 
можете видеть контуры остальных (помимо активного) слоев и при повторном нажатии Shift+S полностью их 
скрыть. Эту настройку вы также можете поменять на панели View Configuration на вкладке View Options (Рис. 12.9).

Рис. 12.9 - Переключение в режим одного слоя в Altium Designer
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Контур печатной платы в OrCAD PCB Designer 
размещается на специальном зарезервированном 
слое (подклассе) Board_Geometry\Outline. Вы можете 
нарисовать его при помощи линий или полигонов. 
Специальным цветом область платы не отличается от 
остального рабочего поля (Рис. 13.1). 

13. СОЗДАНИЕ ШАБЛОНА ТОПОЛОГИИ

В данной разделе будут рассмотрены вопросы создания контура платы, размещения крепежных отверстий и зон 
запрета для трассировки проводников и размещения компонентов.

Создание контура платы

В Altium Designer наличие линий контура 
необязательно. Область печатной платы отображается 
отдельным цветом, который можно настроить через 
панель View Configuration в секции System Colors. Через 
панель Properties вы легко сможете поменять слой 
линии контура. Даже если эта линия была удалена, 
то ее легко восстановить по команде Design » Board 
Shape » Create Primitives From Board Shape. Как 
правило под линию контура выбирается отдельный 
механический слой (Рис. 13.2).

Рис. 13.1 - Контур платы в OrCAD PCB Designer

Рис. 13.2 - Контур физических границ платы на слое 
Mechanical 22
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Область контура физических границ в Altium Designer можно построить несколькими способами:

1.	 Вручную, при помощи линии или другого графического объекта из меню Place

Установите базовую точку через меню Edit » Origin » Set. Выберите линию Place » Line и начните рисовать контур на 
одном из механических слоев, например, Mechanical 1 (дополнительные слои можно активировать через панель 
View Configuration). Вы можете использовать последовательное нажатие клавиш J, L для ввода точек контура по 
координатам. Нарисуйте замкнутый контур, выделите его и используйте команду Design » Board Shape » Define From 
Selected Objects. Новый контур готов.

2.	 Путем загрузки данных из файлов AutoCAD (DXF, DWG)

Выберите File » Import DXF/DWG. Укажите единицы измерения проекта и сопоставьте слои AutoCAD механическим 
слоям Altium Designer. После загрузки контура примените команду Board Shape » Define From Selected Objects.

3.	 Созданием контура из 3D модели в формате STEP, SolidWorks, Parasolid

Перейдите в 3D режим нажатием клавиши 3. Далее выберите команду Place » 3D Body. Через панель Properties 
выберите тип модели Generic. На той же панели выберите кнопку Choose для загрузки модели из внешнего файла. 
После загрузки модели примените команду Design – Board Shape – Define From 3D Body. Эта команда выполняется в 
три действия:

�� необходимо выбрать загруженную деталь платы;

�� затем выбирается лицевая грань;

�� в окне выбора стороны платы достаточно нажать Close с опциями по умолчанию.

После этого контур будет готов. Основное отличие от второго способа заключается в том, что 3D модель может 
содержать вырезы и отверстия, которые автоматически распознаются в Altium Designer. 

Отверстия для крепления платы

Рис. 13.3 - Размещение крепежных отверстий в OrCAD PCB Editor

Крепежные отверстия размещаются как отдельный 
тип символов из файла *.bsm, за размещение 
библиотеки которых отвечает переменная psmpath. 
Вам необходимо создать падстек в Pad Designer. 
Затем создать механический символ в OrCAD PCB 
Editor через меню File » New » Mechanical Symbol. 
Одно механическое отверстие – это два файла *.dra 
и *.bsm. Проще всего механическое монтажное 
отверстие разместить в режиме Placementedit через 
панель Options. При этом в меню Place » Manually вы 
должны выбрать размещение таких символов (Рис. 
13.3).
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В Altium Designer падстеки с отверстиями находятся 
на специальном слое, Multi-Layer.  Монтажные 
отверстия размещаются по команде Place » Pad. Все 
настройки отверстий можно найти на панели Proper-
ties. Размещать их также можно по координатам при 
помощи клавиш J, L (Рис. 13.4).

Зоны запрета для трассировки и размещения компонентов

В Altium Designer вы можете использовать 
специальный слой Keep-Out, на котором размещаются 
зоны запрета. Такую зону можно нарисовать при 
помощи меню Place » Keepout или Active Bar. Команды 
для создания зоны Keep-Out активны только когда 
активным является слой Keep-Out. Также разработчики 
часто делают зону Keep-Out по границе платы.

Отдельно стоит отметить, что через панель Proper-
ties вы можете выбрать то, какие объекты запрещает 
конкретная зона Keepout (Рис. 13.6).

В OrCAD зоны запрета и зоны разрешения формируются 
на разных слоях. Для создания зоны, разрешенной для 
трассировки и размещения используются классы слоев 
Route_Keepin и Package_Keepin соответственно. 
Классы, запрещающие трассировку и размещение 
называются Route_Keepout и Package_Keepout. Вы 
можете нарисовать эти зоны линиями или полигонами. 
Для этого в том числе можно использовать команды 
из меню Setup » Areas. Для упрощения создания 
данных областей можно воспользоваться построением 
эквидистантного контура вдоль границы платы или 
выреза по команде Edit » Z Copy (Рис. 13.5).

Рис. 13.4 - Крепежные отверстия и их параметры на 
панели Properties

Рис. 13.5 - Контрольные зоны для размещения и трассировки 
в OrCAD PCB Editor

Рис. 13.6 - Зона запрета Keepout в виде линий и региона в 
Altium Designer
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14. СОЗДАНИЕ СТЕКА СЛОЕВ И ПЕРЕХОДНЫХ ОТВЕРСТИЙ

В этой части речь пойдет о создании стека слоев печатной платы и описания переходных отверстий.

Создание стека слоев

В OrCAD PCB Editor через меню диалоговое окно Layout Cross Selection (Setup » Cross-Section) вы можете настроить 
стек слоев. Новый слой можно добавить через меню ПКМ в таблице слоев. Всего можно создать три типа слоя: 
Conductor, Plane и Dielectric. Вы можете указать все основные электрические характеристики: толщину, 
диэлектрическую проницаемость, тангенс потерь и т.д. Также для удобства ввода данных по каждому слою можно 
вести справочник слоев через меню Setup » Materials. В любой момент можно поменять значения характеристик 
слоев при помощи кнопки Update Fields в нижней части редактора стека. Опции Show Impedance и Show Diff 
Impedance позволяют задействовать калькулятор импеданса для одиночных сигналов и дифференциальных пар 
соответственно (Рис. 14.1).

Управление структурой слоев в Altium Designer осуществляется через диалоговое окно Layer Stack Manager (Design 
» Layer Stack Manager). Разработчики Altium Designer позаботились, чтобы у пользователя всегда под рукой были 
стандартные наборы слоев. Через кнопку Presets вы можете выбрать шаблон стека для вашего проекта, а затем при 
необходимости отредактировать его. Можно выбрать любую ячейку в таблице слоев и из меню ПКМ добавить или 
удалить слои. Кнопки Move Up/Down под таблицей позволяют менять положение слоя в стеке. Ввод слоев также 
зависит от настройки в правом верхнем углу менеджера стека – парой или по одному (Рис. 14.2).

Fig. 14.1 - Layer stack editor in OrCAD PCB Editor

Рис. 14.2 - Редактор стека слоев печатной платы в Altium Designer
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Рис. 14.3 - Создание стеков для глухих и слепых отверстий 
в проекте OrCAD PCB Editor

Рис. 14.4 - Настройка параметров переходных отверстий в Altium Designer

Создание стека переходных отверстий

В OrCAD стеки отверстий формируются в Pad Designer. В OrCAD PCB Editor в диалоговом окне Blind / Buried Vias (Setup 
» B/B Via Definitions » Define B/B Via) вы можете сформировать глухие и скрытые отверстия, указывая начальный и 
конечный слой для любого стека из библиотеки (Рис. 14.3).

Дополнительно применяемость этих отверстий необходимо указать через Constraint Manager в разделе физических 
ограничений. 

В Altium Designer для размещения переходных отверстий есть отдельная команда Place » Via. Настройка Via также 
происходит через панель Properties и похожа на настройку падстеков. Здесь вы указываете диаметр отверстия и 
контактной площадки. В выпадающем списке Drill Pair вы можете выбрать пару слоев, которые соединяет Via. Вы 
можете задать столько пар слоев, сколько вам необходимо при помощи кнопки Drill Pairs. Такая же кнопка есть и в 
менеджере стеков. В окне Drill-Pair Manager вы можете добавлять каждую пару по отдельности при помощи кнопки 
Add или добавить все возможные варианты с учетом стека платы по кнопке Create Pairs From Layer Stack (Рис. 14.4).

Вы также можете использовать шаблоны переходных отверстий из библиотеки Pad And Via. Чуть позже будет 
рассмотрено специальное правило проектирования, при помощи которого вы можете управлять параметрами Via 
для конкретных цепей и их классов.
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15. УПАКОВКА СХЕМЫ И ПЕРЕХОД К РАЗРАБОТКЕ ТОПОЛОГИИ

В этой части будет рассмотрен вопрос о загрузке данных в редактор печатных плат для начала трассировки и 
размещения. В Altium Designer, у вас есть возможность строго контролировать изменения, которые передаются 
между редакторами.

 Список цепей и сообщение об ошибках

Передача изменений между схемой и платой в OrCAD PCB Designer осуществляется либо из схемотехнического 
редактора, либо из редактора топологии. В первом случае используется диалоговое окно Create Netlist (Tools » Create 
Netlist) (Рис. 15.1).

Здесь нет каких-либо дополнительных опций и все ошибки и предупреждения фиксируются в журнале сообщений 
(Session Log), который доступен через меню Windows » Session Log (Рис. 15.2).

Рис. 15.1 - Окно генерации нетлиста в OrCAD Capture

Рис. 15.2 - Сведения об упаковке схемы в 
журнале сообщений OrCAD Capture
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В OrCAD формируется три файла нетлиста в подпапке allegro в папке проекта: pstxner.dat, pstxprt.dat, pstchip.
dat. Эти три файла тесно взаимосвязаны, и при потере одного из них необходимо заново сгенерировать нетлист. 
Если при генерации система обнаруживает грубые ошибки, то генерация нетлиста прерывается и пользователю 
необходимо исправить все ошибки на основе журнала сообщений.

В OrCAD PCB Editor для передачи изменений из схемы вам доступно меню File » Import » Logic (Рис. 15.3).

Здесь в строке Import directory вам необходимо указать путь к папке с нетлистом. Просмотр лога с ошибками 
возможен через меню File » Viewlog и файл netlist.log.

В Altium Designer для передачи данных на печатную плату из схемного редактора используется команда Design 
» Update PCB Document <название_файла_PCB>. Аналогичную функцию предоставляет команда меню Design » 
Import Changes From <название_проекта_PCB> из топологического редактора. В результате выполнения обеих 
команд на экране возникает список изменений Engineering Change Order. Пользователь в отличие от OrCAD здесь 
не имеет дело с текстовым нетлистом и все изменения и сообщения об ошибках фиксируются в одном окне.

Пользователю для проверки изменений и окончательного их утверждения предлагается нажать на кнопки Vali-
date Changes и Execute Changes соответственно(Рис. 15.4).

Рис. 15.3 - Окно передачи изменений из 
схемы в OrCAD PCB Editor

Рис. 15.4 - Окно передачи данных из схемы в редактор топологии в Altium Designer
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Все изменения делятся на категории, которые вы можете свернуть. Например, в категории Add Nets 
перечисляются все цепи, которые будут переданы в топологию, а напротив каждой цепи слева стоит метка, которая 
разрешает ее передачу. Выберите любое изменение из списка и нажмите ПКМ. В этом меню вы можете выбрать 
различные действия, например, отказаться от передачи изменений конкретной категории. 

В случае, если изменение передать невозможно, и оно не проходит проверку, то появляется красная метка в столбце 
Check. Зеленая метка означает, что изменение проверено и передано в редактор топологии. 

Обратите также внимание на предупреждение, которое может появляется в нижней части окна Engineering Change Or-
der: Warning: Errors Occurred during compilation of the project!. Далее вы можете нажать на надпись Click 
here to review them before continuing для запуска компиляции и вывода списка ошибок на схеме, чтобы вы 
могли исправить наиболее критичные из них.

Обзор объектов в редакторе топологии после первой загрузки

В OrCAD PCB Editor компоненты и цепи не появляются на экране автоматически. Вы можете просмотреть список 
загруженных компонентов, комнат, цепей и дифференциальных пар различными способами. Например, полный 
список компонентов может быть выведен через панель Options в режиме Placement Edit (Рис. 15.5).

Также полный список компонентов и цепей может быть выведен в Constraint Manager, через панель Find, отчеты и т.д. 

В Altium Designer после загрузки данных на печатную плату все компоненты и связи будут размещены справа от 
области платы. Список всех компонентов, цепей, классов будет доступен на панели PCB (Рис. 15.6).

Рис. 15.5 - Список компонентов на панели Options 
в OrCAD PCB Editor

http://www.altium.com/ru


www.altium.com/ru 53

РУКОВОДСТВО ПО ПЕРЕХОДУ C CADENCE OrCAD®

Рис. 15.6 - Компоненты и цепи после загрузки в редактор топологии Altium Designer

В следующих главах мы рассмотрим вопросы компоновки платы и размещения компонентов.
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16. РАЗМЕЩЕНИЕ КОМПОНЕНТОВ

В этой части мы рассмотрим инструменты для размещения компонентов.

Размещение вручную

В OrCAD PCB Editor для размещения компонентов вручную вы можете воспользоваться режимом Placement Edit, при 
работе в котором список компонентов отображается на панели Options. Вы просто выделяете компоненты и ставите 
их в область платы (Рис. 16.1).

Также размещение можно вести при помощи команды меню Place » Manual (Рис. 16.2).

Рис. 16.1 - Размещение компонентов вручную

Рис. 16.2 - Размещение компонентов по команде Place » Manual
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В Altium Designer размещение компонентов вручную 
можно осуществлять схожими с OrCAD способами. 
Поскольку все компоненты, после загрузки данных 
из схемы, размещаются в пространстве редактора 
топологии, то вы можете вручную переносить их по 
одному или группой на область платы. Кроме этого, вы 
можете вывести список компонентов на панели PCB и 
также, как в OrCAD, переносить их из списка на плату 
(Рис. 16.3).

Для быстрого размещения компонентов в OrCAD вы 
можете воспользоваться диалоговым окном Quick-
place (Place » Quickplace). Здесь вам предлагается 
использовать достаточно богатый набор опций. Вы 
можете выбрать размещение на основе свойства 
компонентов, подключенной цепи, номера схемы, 
позиционных обозначений, количества выводов и т.д. 
(Рис. 16.4).

В Altium Designer для быстрого размещений компонентов 
вы можете использовать группу команд Tools » Compo-
nent Placement. Большинство из этих команд работает, 
если вы предварительно выделите компоненты, 
которые необходимо разместить. Например, это можно 
сделать при помощи панели PCB. Установите опцию 
Select и Clear Existing, выделите в классе All Compo-
nents компоненты, которые вы хотите разместить и 
воспользуйтесь командой Tools » Component Placement 
» Arrange Within Rectangle. Далее просто нарисуйте 
курсором в области платы прямоугольник, где должны 
размещаться компоненты (Рис. 16.5).

Быстрое (полуавтоматическое) размещение компонентов

Рис. 16.3 - Размещение компонентов при помощи панели PCB в 
Altium Designer

Рис. 16.4 - Меню быстрого размещений компонентов 
в OrCAD PCB Editror

Рис. 16.5 - Размещение компонентов в прямоугольнике в 
Altium Designer
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Размещение компонентов по схеме

Вы можете выделять компоненты на схеме и ставить 
их посадочные места на плату. Для этого в OrCAD PCB 
Editor необходимо активировать команду размещения 
вручную или нажать на специальную кнопку на панели 
инструментов, которая запускает размещение вручную 
без появления на экране окна со списком символов 
посадочных мест. Далее вы выбираете один или 
несколько компонентов на схеме и последовательно 
ставите их на печатную плату (Рис. 16.6).

В Altium Designer для размещения компонентов по схеме вам необходимо сначала активировать режим 
перекрестного выделения Tools » Cross Select Mode. Далее вы можете выбирать компоненты в схемотехническом 
редакторе. Затем активировать редактор топологии и использовать команду Tools » Component Placement » Ar-
range Within Rectangle (Рис. 16.5).

Конечно есть и другие инструменты в Altium Designer, которые вы можете использовать для размещения 
компонентов. В зависимости от конкретной ситуации вы можете использовать любой из них для повышения 
эффективности вашей работы.

Рис. 16.6 - Размещение компонентов по схеме в OrCAD
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17. СОЗДАНИЕ КЛАССОВ ОБЪЕКТОВ

В этой части мы рассмотрим вопросы связанные с созданием классов цепей и компонентов, дифференциальных пар 
и расширенных цепей (xSignals).

Создание классов компонентов и цепей

В OrCAD PCB Editor классы формируются исключительно через Constraint Manager (Setup » Constraint Manager). В 
любой из категорий правил вы можете выбрать список цепей и из меню ПКМ добавить новый класс (Рис. 17.1).

Состав класса можно посмотреть только через Constraint Manager, который может работать параллельно с OrCAD PCB 
Editor.

Понятия класса компонентов в OrCAD нет. Вы можете создать комнату при помощи специального свойства 
ROOM, которое можно присвоить выбранным компонентам в OrCAD Capture или в Constraint Manager, в разделе 
Properties (Fig. 17.2).

Рис. 17.1 - Создание класса цепей в OrCAD PCB Editor

Рис. 17.2 - Свойство Room в Constraint Manager
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  В Altium Designer создание классов цепей и компонентов имеет важное значение. Во-первых, это упрощает 
управление большими массивами объектов и их визуализацию. Во-вторых, это позволяет назначать правила 
проектирования более избирательно с учетом логического деления схемных каскадов и интерфейсов. Самый 
простой способ сформировать класс цепей в редакторе топологии Altium Designer это использовать меню ПКМ – 
Add Class в секции классов на панели PCB. В появившемся окне укажите название класса, далее перенесите цепи из 
левого списка в правый для включения их в этот класс (Рис. 17.3).

Аналогичным образом через панель PCB формируются классы для компонентов и других объектов.

В Altium Designer есть специальная команда для формирования классов в меню Design » Classes. Здесь вы можете 
создать классы для любого типа объектов. После этого они будут доступны через панель PCB (Рис. 17.4).

Рис. 17.3 - Создание классов цепей через панель PCB в Altium Designer

Рис. 17.4 - Окно создания классов через меню Design » Classes

http://www.altium.com/ru


www.altium.com/ru 59

РУКОВОДСТВО ПО ПЕРЕХОДУ C CADENCE OrCAD®

Создание дифференциальных пар

В OrCAD PCB Editor дифференциальную пару можно создать как в самом редакторе при помощи команды Logic » As-
sign Differential Pair, так и через Constraint Manager. Просто выберите две цепи и из правой кнопки мыши запустите 
команду Create » Differential Pair (Рис. 17.5).

Вы можете создать несколько дифференциальных пар воспользовавшись меню Objects » Create Differential Pair в 
CM и кнопкой Auto Setup (Рис. 17.6).

Рис. 17.6 - Автоматическое создание дифференциальных пар в CM

Рис. 17.5 - Создание дифференциальной пары в OrCAD PCB Editor и CM
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Подобным образом вы можете поступить и в Altium Designer. Самый простой способ создать дифференциальные 
пары – это воспользоваться панелью PCB. В верхней части этой панели выберите тип объектов – Differential 
Pair Editor. Создать все дифференциальные пары автоматически можно при помощи кнопки Create From Nets и 
соответствующего фильтра для цепей (Рис. 17.7).

Там же, на панели PCB у вас есть возможность создать дифференциальную пару вручную при помощи кнопки 
Add (Рис. 17.8).

Рис. 17.7 - Автоматическое создание дифференциальных пар в Altium Designer

Рис. 17.8 - Создание дифференциальной пары вручную в Altium Designer
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Создание расширенных цепей

Под расширенной цепью понимается цепь, которая включает в себя весь путь прохождения сигнала от микросхемы-
источника через цепочку последовательно подключенных дискретных пассивных компонентов до микросхемы-
приемника. Например, в качестве набора расширенных цепей может выступать адресная шина интерфейса DDRx. 

Для создания таких цепей в OrCAD вам необходимо назначить пассивным компонентам так называемые ESpice 
модели. Это можно сделать несколькими способами. Самый простой из них – это меню Analyze » Model Assignment. 
Находясь в этом меню, вам достаточно выбрать на плате пассивные компоненты и нажать на кнопку Create Model и 
выбрать Create ESpiceDevice model (Рис. 17.9).

Автоматически, цепи, которые соединяют данные пассивные компоненты, будут учитываться системой как XNet. 
Список XNet можно увидеть в CM (Рис. 17.10).

Рис. 17.9 - Создание ESpice моделей в OrCAD PCB Editor

Рис. 17.10 - Список XNet в CM
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Вы также можете воспользоваться мастером настройки проекта OrCAD PCB Editor, который включает настройку XNet 
через меню Setup » SI Design Setup (Рис. 17.11).

В Altium Designer расширенные цепи называются xSignals. У разработчика есть несколько методов создания таких 
цепей. При помощи панели PCB вы также можете управлять классами и индивидуальными xSignals (Рис. 17.12).

Рис. 17.11 - Мастер настройки проекта в меню 
Setup » SI Design Setup в OrCAD PCB Editor

Рис. 17.12 - Переход к управлению xSignals на панели PCB в Altium 
Designer
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Для создания xSignals вам достаточно выбрать вывод компонента, нажать Tab, чтобы была выбрана вся цепь, далее 
из меню ПКМ выбрать команду xSignals » Create xSignal from selected pins (Рис. 17.13).

 Для создания группы расширенных цепей вы можете воспользоваться диалоговым окном Create xSignals Between 
Components (Design » xSignals). В этом окне вы можете выбрать микросхемы – источник сигнала, цепи и микросхему-
приемник сигнала. Кнопка Analyze запускает процесс создания xSignals с учетом выбранного критерия, например, 
Through 1 series component – сигнал проходит через один последовательный компонент (Рис. 17.14).

Рис. 17.13 - Создание xSignals вручную в Altium Designer

Рис. 17.14 - Создание xSignals через диалоговое окно Create xSignals Between Components

http://www.altium.com/ru


www.altium.com/ru 64

РУКОВОДСТВО ПО ПЕРЕХОДУ C CADENCE OrCAD®

В меню Design » xSignals » Run xSignals Wizard вы можете запустить мастер создания расширенных цепей. Он 
удобен тем, что позволяет  создать xSignals с уже назначенными ограничениями по задержке сигналов для 
интерфейсов DDR3/DDR4 и USB 3.0, что значительно экономит ваше время (Рис. 17.15).

Рис. 17.15 - Создание xSignals при помощи мастера в Altium Designer
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18. ЗАДАНИЕ ПРАВИЛ DRC

В этой части мы рассмотрим подход к описанию правил, настройки основных правил DRC.

Общий подход к заданию ограничений

Правила и ограничения в OrCAD PCB Editor могут быть заданы через специальный редактор, Constraint Manager. 
Его можно вызвать через меню Setup » Constraints » Constraint Manager. Это табличный редактор, где все правила 
разделены на группы, которые можно видеть на панели Worksheet Selector. Подход к заданию правил в OrCAD 
следующий:

1.	 В каждой группе правил (домене) формируются наборы правил (Constraint Set). Единственный по умолчанию 
шаблон правил Default распространяет свое действие на все цепи проекта. Вы можете создать дополнительные 
шаблоны (Рис. 18.1).

Рис. 18.1 - Шаблоны правил типа Physical в Constraint Manager

Рис. 18.2 - Назначение шаблонов правил на объекты цепей

2.	 Далее в разделе Net вы можете назначить шаблон (Set) на любые цепи и объекты цепей (Рис. 18.2).
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Правила можно назначить индивидуально на каждую цепь, вводя соответствующее значение в ячейках таблицы. 
Значения, введенные пользователем, отображаются синим жирным цветом.

Для задания правил в Altium Designer необходимо перейти в диалоговое окно PCB Rules and Constraints Editor (De-
sign » Rules). В этом окне левой части отображаются различные группы правил, в правой – список всех правил с их 
значениями (Рис. 18.3).

Далее, если, например, вы выберите группу правил Electrical, то справа отобразится список правил только этой 
группы. Если вы перейдете непосредственно к подгруппе Clearance, то увидите все правила зазоров из этой 
подгруппы. Здесь вы можете определить зазоры между любыми объектами цепей на плате. Нажмите ПКМ на 
подгруппе Clearance и выберете New Rule. Новое правило будет добавлено в список. Далее присвойте ему имя 
согласно его параметрам так, чтобы вы потом смогли понять для какой группы цепей оно определено.

Обратите внимание, что каждое новое правило поясняется картинкой, что упрощает интерфейс.

Укажите Minimum Clearance, например, 0,3 мм. Под картинкой вы увидите таблицу. Все значения ячеек изменились 
на 0,3 мм. Здесь ячейка на пересечении строки и столбца определяет зазор между объектами, которые указаны в 
заголовках. Вы можете провести курсором и выделить сразу несколько ячеек и ввести новое значение с клавиатуры. 
Таким образом, система позволяет вам более тонко настроить ограничение (Рис. 18.4).

Рис. 18.3 - Редактор правил и ограничений в Altium Designer
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При необходимости вы можете создать более сложное правило, например, которое будет распространятся только на 
полигоны отдельной цепи на отдельном слое. 

Создание правил в схемотехническом редакторе

В OrCAD Capture ввести ограничения для учета при трассировке вы можете в редакторе свойств. При передаче 
данных в редактор топологии ограничения записываются в таблицу Constraint Manager, где вы можете продолжить 
их редактирование (Рис. 18.5).

Рис. 18.4 - Правило зазоров в Altium Designer

Рис. 18.5 - Ввод ограничений для цепей в редакторе свойств OrCAD Capture
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В Altium Designer в схемотехническом редакторе правила проектирования топологии могут быть заданы при 
помощи специальных меток (директив) из меню Place » Directives » Parameter Set. В настройках данных директив, 
которые вы можете видеть на панели Properties, в секции Rules вы можете добавить одно или нескольких правил. 
Далее вы просто ставите директиву на цепь и тем самым присваиваете ей ограничения на трассировку (Рис. 18.6).

Вы также можете установить правило на группу цепей. Для этого предварительно на метки цепей накладывают 
рамку по команде Place » Directives » Blanket. Затем на эту рамку устанавливают метку правил (Рис. 18.7).

Рис. 18.6 - Метка правил для проектирования топологии в схемотехническом 
редакторе Altium Designer

Рис. 18.7 - Задание правил в Altium Designer Schematic на группу цепей
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Задание базовых правил

1. Правила зазоров.

В OrCAD PCB Editor правила зазоров вы можете задать в группе правил Spacing в Constraint Manager (Рис. 18.8). Вы 
можете сделать это через набор правил зазоров (SCSet), назначить индивидуально (Рис. 18.9), указать в свойствах 
конкретной цепи или объекта, например, полигона.

Рис. 18.8 - Правила зазоров в Constraint Manager

Рис. 18.9 - Индивидуальное свойство с указанием зазора для цепи в OrCAD PCB Editor
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Выше уже приводился пример задания правила зазоров в Altium Designer. Поэтому здесь хотелось бы дополнить  
этот пример описанием сложного правила.

В списке объектов Where The First Object Matches выберите Custom Query, на экране появится окно с 
возможностью записать определение объектов на языке Query. Этот язык очень часто используется в различных 
САПР. Он очень прост, но Altium Designer предлагает вам методологию, по которой вам не потребуется знать 
тонкости этого языка. Просто нажмите на кнопку Query Builder и сформируйте запрос при помощи данного 
построителя (Рис. 18.10).

Вы можете вручную вводить определение для правила. Строка определения обладает технологией IntelliSense, что 
значительно упрощает ввод, так как программа сама предложит вам правильное значение и синтаксис для каждого 
следующего параметра. Это очень просто.

2. Правило ширины трасс и переходных отверстии

В OrCAD правила ширины можно описать в Constraint Manager, в группе правил Physical, указав значения для 
максимальной и минимальной ширины трассы (Рис. 18.11).

Рис. 18.10 - Создание Query запроса для правила

Рис. 18.11 - Описание правила для ширины трасс в OrCAD PCB Editor
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В этой группе правил вы также можете задать описание переходных отверстий. В столбце Vias вы указываете 
отверстия для набора правил или для конкретного объекта цепей. При этом на экране появляется список Edit Via List, в 
котором из списка справа выбираются стеки переходных отверстий, ранее созданные в Padstack Editor (Рис. 18.12).

Правила для ширины трасс в Altium Designer вы можете задать через группу правил Routing – Width. Вы можете 
указать номинальную, минимальную и максимальную ширину для цепи или класса цепей. Также есть возможность 
указать вместо значения ширины импеданс в Омах (Рис. 18.13).

Рис. 18.12 - Задание переходных отверстий в OrCAD PCB Editor

Рис. 18.13 - Правило для ширины проводников класса цепей Power _ Group
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В отличие от OrCAD PCB Editor в Altium Designer нет необходимости создавать отдельный стек для переходного 
отверстия. Достаточно определить его параметры в правилах и при трассировке динамически менять в пределах 
номинального, минимального и максимального размеров. Вы можете задать специфические параметры для 
отдельных цепей или их классов (Рис. 18.14).

3. Правило для паяльной маски

В OrCAD PCB Editor нет отдельного правила, которое регламентировало бы вскрытие в паяльной маске для 
контактных площадок. Этот слой описывается непосредственно при создании падстеков в Padstack Editor. 
При генерации Gerber файлов вы просто объединяете все слои Soldermask в один Gerber и передаете его на 
производство.

В Altium Designer для контроля паяльной маски используется правило группы Mask – Solder Mask Expansion. В этом 
правиле вы можете указать вскрытие паяльной маски сразу для всей платы или для отдельных групп контактных 
площадок. Это избавляет от необходимости задавать маску в падстеках на этапе создания библиотеки посадочных 
мест, хотя у разработчика есть такая возможность (Рис. 18.15).

Рис. 18.14 - Пример правила для переходных отверстий в Altium Designer

Рис. 18.15 - Установка правила для паяльной маски в Altium Designer
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Настройка режимов контроля правил

Режимы контроля правил устанавливаются в Constraint Manager в диалоговом окне Analysis Mode (Analyze » Analysis 
Modes). Вы можете установить контроль онлайн и включить или отключить ту или иную проверку (Рис. 18.16).

В Altium Designer режим контроля правил можно задать через диалоговое окно Design Rule Checker (Tools » Design 
Rule Check) в разделе Rules To Check. Здесь, также как и в OrCAD, правила можно контролировать в режиме онлайн и 
в пакетном режиме (Рис. 18.17).

Рис. 18.16 - Установка режима контроля правил 
в Constraint Manager

Рис. 18.17 - Установка режима контроля правил в Altium Designer PCB Editor
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19. КОНТРОЛЬ ВИДИМОСТИ И ЦВЕТА ЭЛЕКТРИЧЕСКИХ СВЯЗЕЙ

В этой части мы рассмотрим вопросы установки видимости и цвета электрических связей (цепей) в редакторе 
печатных плат.

Контроль видимости связей

Вопрос визуализации объектов топологии должен решаться таким образом, чтобы разработчику было удобно 
работать с ними. Это и выделение наиболее критических цепей, и создание набора видимых слоев, и установка 
параметров прозрачности и др. 

В OrCAD PCB Editor достаточно гибкая система управления видимостью объектов топологии. Для изменения 
видимости линий соединений (Rats) используется группа команд меню Display » Show/Blank Rats (Рис. 19.1).

Например, вы можете выбрать команды Display » Blank Rats » Components и затем на панели Find в поле ввода Find 
By Name ввести нужный Reference Designator – Rats для данного компонента будут погашены. Вы можете провести 
курсором по компонентам или выводам, и их линии связи будут скрыты/показаны на экране.

Давайте посмотрим, как это вопрос решается в Altium Designer.

На панели View Configuration вы можете редактировать системные цвета. Для линий соединений здесь вы можете 
поменять цвет или отключить видимость (Рис. 19.2).

Fig. 19.1 - Connection line visibility options
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Контролировать видимость линий соединений вы можете при помощи клавиши N. Она дает доступ к большинству 
наиболее часто используемых команд, когда нужно погасить или показать все связи или сделать это индивидуально 
для цепи или компонента (Рис. 19.3).

Рис. 19.2 - Изменение настроек  видимости линий соединений на панели View Configuration

Рис. 19.3 - Контроль видимости при помощи клавиши N в Altium Designer
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Вы можете контролировать видимость линий также при помощи панели PCB. Выберите класс цепей или отдельную 
цепь из списка и выберите команду Connections » Show / Hide из контекстного меню. Здесь же вы можете выбрать 
Change Net Color для изменения цвета цепей, что часто является необходимостью. Обратите внимание, что 
напротив каждой цепи в списке на панели PCB отображается ее текущий цвет (Рис. 19.4).

Установка цвета связей

Для назначения цвета цепи достаточно подвести курсор на вывод или любой другой объект, который к ней 
подключен и выбрать Assign Color из контекстного меню и выбрать подходящий цвет для цепи. Для этого также 
используется меню Display » Assign Color с выбором цвета и рисунка на панели Options (Рис. 19.5).

Для снятия подсветки используется команда Display » Dehighlight.

Рис. 19.4 - Изменение видимости линий соединений через панель PCB

Рис. 19.5 -  Установка цвета выделения в OrCAD PCB Editor
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В Altium Designer цветовое выделение для объектов цепей можно установить, поставив опцию выделения в 
боксе напротив каждой цепи на панели PCB – проводники, контактные площадки, ПО и другие объекты этих 
цепей окрасятся в нужный цвет. Для снятия подсветки и ее включения нажмите F5. Непосредственно цвет можно 
установить через меню ПКМ – Change Net Color (Рис. 19.6)

Рис. 19.6 - Установка цвета временной подсветки для объектов цепей на панели PCB
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20. ИНСТРУМЕНТЫ ТРАССИРОВКИ

В данной части будут рассмотрены инструменты трассировки. Altium Designer обладает всеми современными 
средствами интерактивной и автоматической трассировки. Здесь полностью реализуется концепция 
проектирования под управлением ограничений.

Интерактивная ручная трассировка

В Altium Designer все команды трассировки доступны 
в меню Route. На каждую команду вы можете 
назначить горячую клавишу по своему усмотрению. 
Все настройки по умолчанию для интерактивной 
трассировки находятся на странице PCB Editor - Inter-
active Routing диалогового окна Preferences. Проще 
всего рассматривать возможности интерактивной 
трассировки в связке с информационной таблицей 
(Shift+H), которая показывает все параметры 
исполняемых команд, а также панелью Proper-
ties. Запустите команду Route » Interactive Routing, 
выберите вывод любого компонента, и обратитесь к 
информационному окну (Рис. 20.2).

Для пользователя OrCAD PCB Editor предлагаются 
разнообразные инструменты трассировки. Выполнение 
команд напрямую зависит от режима, в котором 
работает пользователь. Для трассировки существует 
специальный режим, Etch Edit, который можно 
активировать при помощи соответствующей кнопки на 
панели инструментов  . Далее, для начала 
трассировки, вы можете выбрать вывод или нитку. 
Все параметры трассировки отображаются на панели 
Options (Рис. 20.1).

Есть также специальная команда меню Route » Con-
nect (горячая клавиша F3). Помимо панели Options при 
трассировке все команды доступны из меню правой 
кнопки мыши, например, Toggle для поворота угла. the 
right-click menu during routing, for example, Toggle for 
turning corner.

Рис. 20.1 - Интерактивная трассировка в OrCAD PCB Editor

Рис.20.2 - Контроль интерактивной трассировки 
при помощи информационной таблицы
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При изменении любого параметра, например, толщины проводника вы увидите как меняется надпись на 
информационной таблице. Нажмите клавишу 3 для изменения ширины проводника. Информационная таблица 
при этом покажет какое значение в данный момент используется – минимальное, номинальное или максимальное 
согласно правилам проектирования. Также есть режим User Choice, когда вы можете выбрать ширину из 
предпочтительного списка значений, нажав Shift+W.

Использование горячих клавиш в Altium Designer играет решающее значение. Для вызова списка всех доступных 
клавиш просто нажмите  кнопку ~ (тильда). Это отличная подсказка для начинающих пользователей. Помните, что 
эта подсказка работает только когда вы выполняете какое-то действие и не работает, когда ни одна команда не 
запущена.

Вот список наиболее часто используемых горячих клавиш при интерактивной трассировке:

�� Пробел – поворот угла трассы

�� Shift+Пробел – изменения угла трассировки

�� Shift+R – изменение режима обхода/расталкивания препятствий

�� 3 – изменение ширины трассы

�� Shift+W – выбор ширины трассы из предпочтительного списка

�� Num +/- – смена слоя - установка переходного отверстия

�� 4 – выбор параметров переходного отверстия

�� Shift+V – выбор стиля переходного отверстия

�� Ctrl+Shift+G – смена режима глоссинга

Вы можете также нажать Tab и все параметры текущей трассировки вы сможете отредактировать на панели Proper-
ties. Обратите внимание, что для каждого параметра отображается горячая клавиша (Рис. 20.3).

Рис. 20.3 - Параметры интерактивной 
трассировки на панели Properties
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Авто-интерактивная трассировка

Помимо интерактивной ручной трассировки Altium Designer обладает передовыми технологиями авто-
интерактивной трассировки, которая называется ActiveRoute. Для ее использования рекомендуется открыть панель 
PCB ActiveRoute. Выделите линии соединений (шину) сигналов, нажмите кнопку Route Guide на панели PCB ActiveRoute, 
постройте маршрут прокладки трасс и нажмите кнопку ActiveRoute (Рис. 20.4).

Рис. 20.4 - Авто-Интерактивная трассировка с применением ActiveRoute
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21. РАБОТА С ПОЛИГОНАМИ

В этой части будет рассказано о работе с полигонами в Altium Designer. Здесь, как и во всех предыдущих случаях, 
разработчику предоставляются разнообразные инструменты для управления заливкой и формой полигонов.

Правила подключения выводов и переходных отверстий к полигонам

В OrCAD PCB Editor различают два типа полигонов: статические и динамические. Для сигнальных слоев используют 
динамические полигоны, так как они автоматически обновляются и легче редактируются. Статические полигоны 
используют для описания всевозможных зон и границ. В частности, границы областей Keepin и Keepout – это 
статические полигоны. 

Настройки динамических полигонов можно найти в диалоговом окне Dynamic Shape Instance Parameters (Shape » 
Global Dynamic Parameters). Здесь можно выбрать режим динамической заливки Smooth, Rough и Disabled. Чаще 
всего используется Smooth для полного соответствия заданным ограничениям. Остальные состояния используются, 
когда необходимо, например, снизить размер файла BRD, провести автоматическую трассировку (Allegro PCB 
Router (SPECCTRA) не работает с динамическими полигонами) и т.д. На вкладке Clearances можно определить 
параметры вырезов для PTH/SMD, Via, проводников и других объектов. На вкладке Thermal relief connects вы можете 
определить параметры термобарьеров (Рис. 21.1).

В OrCAD PCB Editor вы можете определить параметры подключения КП к полигону на уровне правил DRC (правила 
типа Spacing), отдельных полигонов или даже отдельных выводов, что значительно упрощает работу. Вам 
достаточно выбрать вывод и перейти к его свойствам, где вы указываете какой тип подключения вам необходим.

Правила подключения полигонов к контактным площадкам в Altium Designer определяется правилами DRC. Для 
редактирования этих правил необходимо перейти в меню Design » Rules в раздел правил Plane – Polygon Connect 
Style (Рис. 21.2).

Рис. 21.1 - Параметры подключения выводов и переходных отверстий к полигонам
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Вы можете настроить правила для конкретного полигона и контактных площадок. Для этого можно воспользоваться 
построителем запросов в описании правила.

Два других правила Power Plane Connect Style и Power Plane Clearance относятся к слоям типа Plane. Этот тип слоев 
по умолчанию содержит сплошную заливку. В Altium Designer трассировка на слоях типа Plane не допускается.

Редактирование полигонов

Основным меню для создания полигонов является меню Shaре и соответствующая панель инструментов  
  . Кроме этого, вы можете перейти в специальный режим Shape Edit для работы с полигонами. В этом 

режиме на панели Options доступно большинство опций редактирования полигонов (Рис. 21.3).

Рис. 21.2 - Выбор стиля подключения полигона в Altium Designer

Рис. 21.3 - Инструменты по редактированию 
полигонов в OrCAD PCB Editor
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Например, выберите действие которое вы хотите выполнять по щелчку мыши (Click) – Slide (растягивание), Move 
(перемещение), Add Notch (добавление сегмента по двум точкам). Точно также вы можете выбрать действие для 
захвата и удержания (Drag). Здесь вы также найдете удобные инструменты для работы с углами.

Особенно хочется отметить команду Edit » Z-Copy, которая позволяет создавать эквидистантную копию полигона на 
любом слое с опциями расширения (Expand) и уменьшения (Contact).  Такие же команды присутствует в меню ПКМ, 
если просто навести курсор на границу любого сигнального полигона.

В Altium Designer для рисования полигонов применяется команда Place » Polygon Pour. В этом же меню вы найдете 
команды для создания вырезов в полигонах (Cutout) и разделения полигона на части (Slice). При рисовании вы 
можете использовать горячие клавиши Shift+Пробел и Пробел для изменения угла рисования и направления 
соответственно. 

Все параметры полигонов отображаются на панели Properties. Здесь вы можете назначить цепь полигону, задать 
опции заливки, задать имя или поставить опцию Auto Naming (Рис. 21.4).

Инструменты редактирования полигонов в Altium Designer достаточно интуитивны. При выделении полигонов 
появляются габаритные и центральные точки. Вмещать вы можете перемещать их, меняя размеры полигона. 
Если захватить узловую точку, то при ее перетаскивании вы можете менять угол при помощи горячих клавиш 
Shift+Пробел (Рис. 21.5).

Рис. 21.4 - Параметры полигона на панели Properties

Рис. 21.5 - Редактирование полигонов в Altium Designer

http://www.altium.com/ru


www.altium.com/ru 84

РУКОВОДСТВО ПО ПЕРЕХОДУ C CADENCE OrCAD®

Вы также можете найти дополнительные команды редактирования, такие как сшивание и вычитание 
пересекающихся полигонов, а также редактирование границы полигона в меню ПКМ – Polygon Actions (Рис. 21.6).

Приоритет заливки

В OrCAD PCB Editor вы можете менять приоритет заливки для любого полигона в режиме Shape Edit или при 
выполнении команды Shape Select в меню ПКМ – Raise/Lower Shape Priority (Рис. 21.7).

Рис. 21.6 - Дополнительные команды редактирования полигонов в Altium Designer

Рис. 21.7 - Изменение приоритета заливки 
пересекающихся полигонов в OrCAD PCB Editor
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В Altium Designer аналогичным образом вы можете 
использовать команды Polygon Actions » Bring To Front/
Send To Back из контекстного меню (Рис. 21.8).

В Altium Designer вы можете задействовать механизм 
автоматической перезаливки полигонов, подобно 
тому, как это происходит в OrCAD PCB Editor. Для 
этого перейдите на страницу PCB Editor - General 
диалогового окна Preferences и установите опции Re-
pour Polygons After Modification и Repour all dependent 
polygons after editing (Рис. 21.9).

В OrCAD PCB Editor отображение полигонов 
контролируется в диалоговом окне Color Dialog (Display 
» Color Visibility) на вкладке Display. Здесь вы можете 
управлять прозрачностью полигонов (Рис. 21.10).

Отображение полигонов

Рис. 21.8 - Выбор приоритета заливки в Altium Designer

Рис. 21.9 - Опции автоматической перезаливки полигонов

Рис. 21.10 - Управление прозрачностью полигонов 
в OrCAD PCB Editor
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Вы можете сделать полигоны полностью невидимыми и отобразить только их границы в классе слоев Boundary.

В Altium Designer вы также с легкостью сможете управлять прозрачностью полигонов. Для этого откройте панель 
View Configuration и вкладку View Options. Здесь в разделе Object Visibility настройте уровень прозрачности для 
любых объектов, включая полигоны, установить контурный (Draft) режим отображения (Рис. 21.11).

Используйте команду Polygon Actions » Shelve Selected из контекстного меню, чтобы скрыть полигон. Показать 
полигоны можно через меню Tools » Polygon Pours » Restore Shelved Polygons.

Наиболее интересным и продуктивным инструментом для управления полигонами в проекте является Polygon Man-
ager, доступ к которому вы можете получить все из того же меню Tools » Polygon Pours. В Polygon Manager вы можете 
создавать новые полигоны, делать перезаливку для всего проекта, менять правила проектирования, копировать, 
менять цепи подключения и многое другое (Рис. 21.12).

Например, вы можете нажать на кнопку Create New Polygon from » Board Outline. Будет создан полигон в размер 
границы платы, для которого вы сможете подключить цепь и назначить слой.

Рис. 21.11 - Настройка прозрачности полигонов

Рис. 21.12 - Диалоговое окно Polygon Manager
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22.  ПРОВЕРКА DRC И УСТРАНЕНИЕ ОШИБОК

В этой части мы рассмотрим поиск и устранение ошибок в Altium Designer. Программа предлагает пользователю 
широкий набор средств контроля DRC, такие как маркеры ошибок, панель PCB Rules And Violations, панель Messages и 
ряд других. Вы сможете быстро освоить данный механизм, так как здесь есть много сходств с тем, как вы привыкли 
это делать в OrCAD PCB Designer.

Отчет DRC и визуальный контроль ошибок

В Altium Designer для запуска проверки и вывода 
отчета по ошибкам используется диалоговое окно 
Design Rule Checker (Tools » Design Rule Check). При 
этом на экран выводятся настройки контроля ошибок, 
например, Create Report File для вывода отчета, 
Sub-Net Details для вывода детального маркера и 
другие. В секции Rules To Check вы выбираете режим 
контроля правил – об этом было рассказано в разделе 
18 данного руководства. Генерация отчета по ошибкам 
начинается при нажатии на кнопку Run Design Rule 
Check (Рис. 22.2).

В OrCAD PCB Editor для вывода отчета по ошибкам вы 
используете диалоговое окно Design Rules Check (DRC) 
Report (Tools » Quick Reports » Design Rules Check 
Report) для вывода полного списка ошибок и Design 
Rules Net Shorts Check (DRC) Report (Tools » Quick Reports 
» Design Rules Net Shorts Check Reports) для вывода 
списка по наиболее грубым ошибкам образования 
нежелательного контакта разных цепей. В столбце 
DRC Marker Location показаны координаты в виде 
гиперссылок на места ошибок. В местах ошибок 
отображаются специальные маркеры – «бабочки». 
При наведении курсора на маркер выводится 
наименование ошибки во всплывающей подсказке 
(Рис. 22.1).

Рис. 22.1 - Поиск ошибок через диалоговое окно Design Rules 
Check (DRC) Report в OrCAD PCB Editor

Рис. 22.2 - Настройка вывода отчета по ошибкам в Altium Designer
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После этого на экран выводится подробный отчет 
в формате HTML, где каждая ошибка отмечена 
гиперссылкой на соответствующее положение на 
плате. Отчет вы можете расположить в отдельном окне 
для удобства навигации. Места ошибок отмечаются 
маркерами в виде восклицательных знаков зеленого 
цвета. Помимо этого, вы видите дополнительный 
детальный маркер в обозначении ошибки, 
специфический именно для данного нарушения. 
Например, при нарушении зазора выводится заданное в 
правилах расстояние (Рис. 22.3).

В OrCAD PCB Designer маркеры ошибок выводятся 
на специальном зарезервированном слое DRC Error 
Class. Вы можете контролировать цвет и видимость 
маркеров через панель Options для соответствующего 
подкласса или через панель Visibility (Рис. 22.4).

В Altium Designer вы можете контролировать стиль 
и параметры отображения маркеров ошибок на 
странице PCB Editor - DRC Violation Display page of 
the Preferences. На панели View Configuration в секции 
System Colors вы также можете контролировать цвет и 
видимость маркеров (Рис. 22.5).

Рис. 22.3 - Поиск ошибок в Altium Designer

Рис. 22.4 -Контроль цвета и видимости маркеров 
ошибок в OrCAD PCB Editor

Рис. 22.5 - Контроль цвета и видимости маркеров 
ошибок в Altium Designer
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Панель PCB Rules And Violations

Дополнительным удобным инструментом поиска и 
устранения ошибок в Altium Designer является панель 
PCB Rules And Violations. Эта панель разбита на три 
секции. В верхней перечислены все группы правил, 
ниже подгруппы правила и в последней секции 
выводится список ошибок, соответствующих данному 
правилу. Панель интерактивна и позволяет быстро 
находить и маскировать места ошибок. Для этого в 
верхней части панели из выпадающего списка вы 
можете выбрать режим Mask, а также активировать 
опции Select, Zoom и Clear Existing для выделения и 
масштабирования ошибок, выделенных из списка на 
панели PCB Rules And Violations (Рис. 22.6).

Рис. 22.6 - Поиск ошибок через панель PCB Rules And Violations
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23. ПОДГОТОВКА ВЫХОДНЫХ ДАННЫХ ДЛЯ ПРОИЗВОДСТВА

В этой части мы рассмотрим процесс вывода данных для производства. В Altium Designer наряду с традиционными 
поддерживаются все современные производственные форматы данных, такие как Gerber X2, ODB++ и IPC 2581. Вы 
также можете использовать специальный файл с шаблонами настроек выходных данных Output Job.

Настройка и генерация Gerber файлов

Подготовка данных для производства в OrCAD PCB Designer происходит через меню Manufacture. При помощи 
диалогового окна Artwork Control Form (Manufacture » Artwork) вы можете вывести файлы Gerber. На вкладке Gen-
eral Parameters вы выбираете единицы измерения, тип и формат для Gerber файлов. На вкладке Film Control по 
умолчанию вам доступны для генерации все сигнальные слои. Дополнительно, вручную вы можете создавать наборы 
слоев для Gerber при помощи меню правой кнопки мыши. Вы выбираете название файла и слои, которые будут в нем 
содержаться (Рис. 23.1).

Рис. 23.1 - Настройка вывода Gerber файлов в OrCAD PCB Designer
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Генерация Gerber файлов начинается по команде Create Artwork. Если установлена опция Check database before 
artwork, то дополнительно проверяется наличие неисправленных ошибок. Файлы Gerber записываются в папку mfg в 
папке с вашим файлом *.brd (Рис. 23.2).

Вы также можете загрузить Gerber файлы для просмотра в OrCAD PCB Designer через меню File » Import Artwork. Это 
как правило делается в отдельном файле *.brd с целью визуального контроля данных Gerber.

В Altium Designer вывод Gerber файлов происходит через диалоговое окно Gerber Setup (File » Fabrication Outputs » 
Gerber Files). На вкладке General вы указываете единицы измерения и формат файлов. На вкладке Layers отмечаете 
слои. Вы можете выбирать слои по одному, активируя их в столбце Plot. Вы можете отметить одновременно все 
электрические слои, отметив класс Electrical Layers (Рис. 23.3). Можно сформировать пользовательские классы слоев 
через диалоговое окно Object Class Explorer (Design » Classes), для упрощения их вывода в Gerber.

Рис. 23.2 - Вывод Gerber файлов в OrCAD PCB Designer

Рис. 23.3 - Настройка вывода Gerber файлов в Altium Designer
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В правой части данного окна вы можете выбрать механические слои, которые необходимо вывести в Gerber, 
например, контур платы.

В Altium Designer все выходные данные записываются в подпапку с проектом Projects Output For <название_
проекта>. Gerber файлы здесь имеют расширение в соответствии с названием слоя, например *.gtl – ger-
ber top layer, *.gbs – gerber soldermask. В структуре проекта на панели Projects выходные файлы записываются в 
поддиректорию Generated\CAMtastic Documents, откуда их можно вывести на экран (Рис. 23.4).  

На самом деле после генерации Gerber файлы автоматически выводятся на экран в специальном технологическом 
редакторе CAMtastic, который интегрирован в Altium Designer.  Для данного редактора запускается панель CAMtastic, на 
которой можно включить или отключить отображение Gerber файлов (Рис. 23.5).

Рис. 23.4 - Gerber файлы в Altium Designer

Рис. 23.5 - Технологический редактор CAMtastic в Altium Designer
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Таблица отверстий и файл сверловки

Таблица отверстий в OrCAD PCB Editor генерируется по команде меню Manufacture » NC » Drill Legend. Для этого 
выделен специальный слой Manufacturing\NClegend. В окне Drill Legend вы можете выбрать шаблон для таблиц, 
сортировку данных и др. (Рис. 23.6).

Если необходимо настроить обозначения отверстий на плате, то это можно сделать через диалоговое окно Drill 
Customization (Manufacture » NC » NC Drill Customization). Здесь вы можете вручную подобрать символ и знак для 
каждого отверстия или сделать это автоматически при помощи кнопки Auto generate symbols, а затем повторить 
сгенерировать таблицу сверловки заново (Рис. 23.7).

Рис. 23.6 - Вывод таблицы сверловки в OrCAD PCB Editor

Рис. 23.7 - Настройка данных для таблицы сверловки в OrCAD PCB Editor
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Генерация файлов сверловки происходит в диалоговом окне NC Drill (Manufacture » NC » NC Drill). Для генератора 
дополнительные параметры, такие как единицы измерения и формат настраиваются по кнопке NC Parameters. По 
нажатию на кнопку Drill файлы сверловки с расширением *.drl записывается в папку mfg (Рис. 23.8).

В Altium Designer таблица сверловки выводится по команде Place » Drill Table на специальный слой Drill Drawing. Все 
настройки таблицы доступны на панели Properties (Рис. 23.9).

Рис. 23.8 - Настройка параметров файлов сверловки в OrCAD PCB Editor

Рис. 23.9 - Таблица сверловки в Altium Designer
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Также на панели Properties в нижней части вы можете нажать кнопку Edit Columns для перехода к редактированию 
состава и названий столбцов, через кнопку Drill Symbols можно отредактирвоать символы отверстий. Здесь вы можете 
выбрать обозначение в виде знака или символа (Рис. 23.10).

Вывод файлов сверловки в Altium Designer происходит в диалоговом окне NC Drill Setup (File » Fabrication Outputs » 
NC Drill Files). В окне NC Drill Setup необходимо указать стандартные настройки, как и в OrCAD PCB Editor. Файл имеет 
расширение *.txt и попадает в папку Project Output For… Как и Gerber файлы, NC Drill файлы выводятся на экран 
в редакторе CAMtastic, а сам файл записывается в структуру проекта в поддиректорию Generated\CAMtastic Docu-
ments на панели Projects (Рис. 23.11).

Рис. 23.10 - Редактирование символов отверстий в Altium Designer

Рис. 23.11 - Вывод файлов сверловки в Altium Designer
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Файлы Output Job

Для упрощения настройки вывода производственной информации в файлы и на печать в Altium Designer используется 
специальный тип файлов Output Job. Вы можете добавить такой файл в проект стандартным способом. Такой файл 
имеет расширение *.Outjob и хранится в структуре проекта. Для добавления настроек достаточно нажать на кнопку 
в любом из разделов выходной информации, например, Add New Fabrication Outputs (Рис. 23.12).

Если вы добавили таким образом Gerber файлы, то по двойному щелчку мыши на экран будут выведены настройки, 
которые были рассмотрены ранее.  Далее выберите подходящий контейнер, например, файловый. И выберите 
позицию выходных данных – на экране появится стрелка, показывающая путь вывода информации (Рис. 23.13).

Рис. 23.12 - Настройка выходных данных через файл Outjob

Рис. 23.13 - Выбор контейнера выходных данных
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ПРИЛОЖЕНИЕ А. НАСТРОЙКА И ЗАПУСК ТРАНСЛЯТОРА ФАЙЛОВ CADENCE ORCAD 

В ALTIUM DESIGNER

Как уже отмечалось выше Altium Designer позволяет вам транслировать данные практически из любой системы 
проектирования. Перед запуском мастера по трансляции необходимо убедится в том, что необходимый вам 
транслятор для OrCAD/Allegro уже установлен. После запуска Altium Designer перейдите в настройки установленных 
модулей – нажмите кнопку Extension And Updates в правом верхнем углу программы и далее щелкните по кнопке 
Configure (Рис. А.1).

В разделе Importers/Exporters вы найдете список всех доступных трансляторов из сторонних электрических САПР. 
Для импорта файлов из OrCAD PCB Designers нам потребуется трансляторы файлов OrCAD и Allegro, так как обе САПР 
работают на единой программной платформе с общим редактором схем OrCAD Capture и редактором топологии Or-
CAD/Allegro PCB Editor (Рис. А.2).

Рис. А.1 - Переход к списку установленных трансляторов

Рис. А.2 - Установленные трансляторы OrCAD и Allegro
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После проверки установленных трансляторов перейдем в меню File » Import Wizard. В появившемся окне нажмите 
Next. Именно здесь находится помощник по трансляции данных и именно отсюда запускаются трансляторы файлов 
OrCAD: библиотек (*.olb), схемы (*.dsn) и платы (*.brd) (Рис. А.3).

Нет смысла подробно описывать дальнейшие шаги по трансляции данных в данном помощнике, так как они 
интуитивно понятны и хорошо описаны на каждом шаге работы помощника по нажатию кнопки Next. Вы в принципе 
можете не обращать внимание на настройки каждого шага и просто нажимать Next до момента, когда кнопка Finish 
станет активной и на экране появится ваш транслированный проект.

Как вы наверно уже заметили для трансляции всего проекта OrCAD нам потребуется запустить Import Wizard два раза 
– отдельно для схемы (*.dsn) и отдельно для топологии платы (*.brd), а затем объединить схему и плату в единый 
проект. Вы также можете транслировать файлы топологии из устаревшей версии OrCAD Layout (*.max), которая 
была снята Cadence с производства в 2009 году, если для вас это актуально. Обратите внимание, что Import Wizard не 
позволяет транслировать библиотеки посадочных мест OrCAD (*.psm) и других типов символов напрямую. Но это не 
должно быть препятствием для вас, так как после трансляции файла топологии все необходимые библиотеки PCB вы 
сможете извлечь из него одной командой за считанные секунды. 

Перед трансляцией файла топологии (*.brd) рекомендуется внести в него ряд изменений:

1.	 Удалить все фэнауты по команде Route » Via Structure » Delete. Сделайте это для Pins, Vias и Clines.

2.	 Удалите полигоны, внутри которых находятся другие полигоны. Как правило такая ситуация складывается на 
внутренних слоях типа Plane с полигонами питания и заземления. После трансляции вы сможете при помощи 
менеджера полигонов быстро воссоздать недостающие полигоны в границах платы или зоны, разрешенной для 
трассировки. 

В качестве примера, который мы разберем в данном руководстве, будет проект из папки C:\Cadence\SPB_16.6\
share\orcad\examples\pcbdesign\pcbdemo1 под названием Demo.opj, который по умолчанию доступен 
пользователям OrCAD PCB Designer, начиная с версии 16.6-2015 (Hotfix 51). Это довольно большой проект со сложной 
иерархией и многослойной печатной платой.

Рис. А.3 - Выбор типа файлов для трансляции
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ПРИЛОЖЕНИЕ Б. ИНСТРУМЕНТЫ СОЗДАНИЯ БИБЛИОТЕК

В Altium Designer для создания библиотек вы можете использовать меню File » New » Library. Здесь создаются 
схемотехнические библиотеки, библиотеки топологических посадочных мест, библиотеки падстеков. Все очень 
интуитивно и понятно. 

Далее для каждой библиотеки становится активной своя специальная панель. При создании схемотехнической 
библиотеки вы используете панель SCH Library, на которой выводит перечень компонентов. Через меню Tools » New 
Component вы можете добавлять новые компоненты. Для каждого компонента на панели Properties вводятся основные 
и дополнительные атрибуты (Рис. Б.1).

Прежде всего, это такие свойства Design Item ID – название компонента, Designator – позиционное обозначение и 
поле Comment, где указывается как правило полное название модели компонента. В строке Designator и Comment 
при помощи кнопки  можно включить или отключить видимость свойств на схеме. Обратите внимание, что по 
умолчанию Designator и Comment не отображаются. На панели Properties внизу можно включить их отображение 
при помощи опции Show Comment/Designator, однако это не является обязательным.

Последовательность создания символов достаточно проста (Рис. Б.2).

1.	 Размещаются выводы по команде Place » Pin или при помощи соответствующей кнопки Active Bar. Можно 
размещать выводы целыми группами по команде Edit » Paste Array.

2.	 Свойства выводов, такие как номер и наименования редактируются на панели Properties.

3.	 Далее при помощи инструментов меню Place размещается графика.

Рис. Б.1 - Выбор компонента на панели Sch Library и его основные свойства на панели Properties
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Обязательно попробуйте в работе инструмент Tools » Symbol Wizard, который поможет Вам в работе над 
многовыводными компонентами. Здесь вы найдете схожий по функционалу инструмент для создания символов, 
как в OrCAD Capture – New Part From SpreadSheet, но более наглядный и мощный. Вы можете скопировать в буфер 
обмена Windows информацию о выводах и просто вставить ее через Symbol Wizard – Altium Designer автоматически 
сформирует для вас готовый символ с заданной конфигурацией расположения этих выводов.

Дополнительные атрибуты, такие как Manufacturing Part Number, Value и другие можно задать для компонента через 
панель Properties на вкладке Parameters. На вкладке Pins редактируются свойства выводов.

Если вы работаете с многосекционным компонентом, то для добавление новых секций используйте команду Tools » 
New Part. Для каждой секции, даже если компонент однородный, необходимо добавить графику вручную. 

По завершению работы над схемотехнической библиотекой запускается проверка из меню Reports » Component 
Rule Check.

Библиотека топологических посадочных мест создается по команде File » New » Library » PCB Library. Здесь вы 
будете работать с панелью PCB Library, где отображается список всех посадочных мест. Новое посадочное место 
можно добавить по команде Tools » New Blank Footprint. Перед началом размещения графики и выводов вам 
необходимо настроить единицы измерения, шаг сетки и привязку. Все это как и в предыдущих разделах делается на 
панели Properties. Все эти настройки носят интуитивный характер. 

Особо хочется отметить задание сетки. Конечно, ничто не мешает вам изменить шаг простым нажатием на кнопку 
G. Но вы можете дополнительно к глобальной сетке создать свои дополнительные сетки, включая, например, 
полярную. Для этого на панели Properties в секции Grid Manager нажмите кнопку Add и выберите прямоугольную 
или полярную сетку, а затем сделайте двойной щелчок ЛКМ по новой позиции в списке сеток. Перед вами появится 
Grid Manager, где можно указать нужный шаг и стиль вашей сетки (Рис. Б.3).

Рис. Б.2 -  Создание графики символа

Рис. Б.3 - Редактирование новой сетки через панель Properties в Grid Manager
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1.	 Разместите выводы по команде Place » Pad

Здесь в отличие от OrCAD вы можете не создавать 
специальную библиотеку падстеков. При размещении 
нового падстека просто задайте его свойства через 
панель Properties – размер отверстия, металлизацию, 
форму и размер контактной площадки, Designator. 

2.	 Разместите графику для шелкографии (слой Top/
Bottom Overlay)

Например, можно воспользоваться инструментом 
Place » Line. Все необходимые свойства линии 
отобразятся на панели Properties.

3.	 Разместите слой сборки (слои типа Mechanical)

Вся вспомогательная информация, такие физические 
и производственные границы компонента, различные 
вспомогательные надписи и т.п. в Altium Designer 
размещается на механических слоях. Вы можете 
активировать дополнительные механические слои 
через панель View Configuration (Рис. Б.4).

4.	 При необходимости добавьте 3D модель при 
помощи меню Place » 3D Body

Перейдите в 3D среду при помощи кнопки 3. Здесь 
на панели Properties выберите 3D model type Gener-
ic и добавьте модель при помощи кнопки Choose. 
Поддерживаются модели STEP, Parasolid, SolidWorks.

Если нет необходимости в полной 3D модели, то 
добавьте упрощенную по команде Tools » Manage 3D 
Bodies For Current Component. Быстро и удобно!

И наконец, создание падстеков происходит по команде 
File » New » Library » Pad Via Library. Здесь все делается 
через па-нель Pad Via Library и редактор Pad Template 
Editor (Рис. Б.5).

При создании посадочных мест просто подключите 
Pad Via Library через панель PCB Pad Via Template и 
разместите нужные падстеки и Via на Layout.

Рис. Б.4 - Активация механического слоя 
на панели View Configuration

Рис. Б.5 - Создание падстеков в Pad Via Library

Начало координат отмечено окружностью с перекрестием в рабочем пространстве. Переместить его вы сможете при 
помощи команды Edit » Set Reference » Origin. 

После подготовительных этапов вы можете начать размещение выводов и графики. Опять же все необходимые 
инструменты у вас всегда под рукой в Active Bar. Порядок следующий:
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ПРИЛОЖЕНИЕ В. УПАКОВКА СХЕМЫ И ПЕРЕХОД К РАЗРАБОТКЕ ТОПОЛОГИИ 

ПОСЛЕ ТРАНСЛЯЦИИ ПРОЕКТА ИЗ ORCAD

Вы уже знаете, что проект передается в Altium Designer по частям. Вначале передается схема, а затем в отдельный 
проект плата. Файлы PrjPcb, SchDoc и PcbDoc должны хранится в одной директории и в одном проекте для того, 
чтобы поддерживать целостность данных и во избежание потери файлов проекта в будущем. Файл платы DemoJ-com-
plete.PcbDoc мы скопировали в папку с проектом DEMOJ и подключили к нему. 

Для синхронизации позиционных обозначений схемы и платы в Altium Designer используется уникальный 
идентификатор, который по умолчанию присваивается каждому компоненту на схеме. При трансляции топологии из 
OrCAD PCB Editor уникальный идентификатор не присваивается, потому что соответствие существующей схеме не 
гарантируется. Тем не менее существует упрощенная процедура синхронизации уникальных номеров между схемой 
и платой:

1.	 Откройте плату DemoJ-complete.PcbDoc и 
перейдите в диалоговое окно Edit Component Links с 
помощью команды Project » Component Links  
(Рис. B.1).

В левом и правом столбцах список компонентов 
схемы и платы соответственно. Вы можете выбрать 
пару в обоих столбцах и нажать > для синхронизации. 
При этом во втором столбце справа появится 
синхронизированный компонент. Для больших 
проектов ручная синхронизации может занять 
значительное количество времени.

В противовес ручной синхронизации вы можете 
использовать автоматическую на основе комбинации 
позиционного обозначения, параметра Comment и 
Footprint. Это позволит мгновенно синхронизировать 
большую часть компонентов.

2.	 Активируйте опцию Designator и отключите Com-
ment и Footprint.

3.	 Нажмите Add Pairs Matched By >>. Произойдет 
автоматическая синхронизация (Рис. B.2).

4.	 Все остальные компоненты необходимо 
синхронизировать вручную. После завершения 
необходимо нажать Perform Update для 
окончательного внесения изменений. 

Рис. B.1 - Окно синхронизации уникальных 
номеров компонентов Edit Component Links

Рис. B.2 - Синхронизация позиционных 
обозначений в Altium Designer
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Ряд компонентов могут быть установлены только 
на плате, не имея символа на схеме. Например, это 
экраны, прокладки, хомуты, монтажные отверстия и 
другие компоненты. Также ряд компонентов может 
присутствовать на схеме, но не иметь посадочного 
места.

Altium Designer поддерживает различные типы 
компонентов. Вы можете просмотреть их на панели 
Properties (Рис. B.3).

В проекте Altium Designer для передачи данных между 
схемой и платой не используется нетлист как таковой. 
Т.е. вам не требуется отслеживать папку с текстовыми 
или ASCII файлами нетлиста, так как вся информация 
передается в «бесшовном» режиме и на экран 
выводятся сведения обо всех изменениях. Если в схеме 
присутствуют ошибки, система сообщит вам об этом.

Для передачи изменений DEMOJ из редактора схемы 
выполните команду Design » Update PCB Document 
DemoJ-complete.PcbDoc или вы можете через редактор 
топологии выбрать команду Design » Import Chang-
es From DemoJ.PrjPcb. Появится окно с запросом на 
ручную синхронизацию цепей (Рис. B.4).

Здесь лучше всего нажать No и приступить к загрузке изменений (ECO). 

Одна из наиболее важных задач – это переименование цепей. В главе «Создание соединений» мы обсуждали какое 
соглашение по системным именам цепей принято в Altium Designer. Настоятельно рекомендуется переименовать во 
время ECO названия цепей OrCAD PCB Designer на названия Altium Designer, как показано ниже (Рис. B.5).

Рис. B.3 - Типы компонентов

Рис. B.4 - Ручная синхронизация цепей

Рис. B.5 - Переименование цепей во время процесса ECO
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Вы также увидите здесь другие изменения, которые предложит сделать программа. Все эти изменения можно 
проконтролировать через диалоговое окно опций проекта (Project » Project Options). Altium Designer предложит по 
умолчанию создать комнаты, классы цепей и компонентов и др.

На вкладке Class Generation вы можете контролировать создание комнат и классов. По умолчанию Altium Designer 
предлагает создавать комнаты и классы цепей по каждому листы схемы. Вы можете просто отключить эту опцию 
(Рис. B.6).

На вкладке Comparator настраиваются опции для поиска отличий между схемой и платой. Вы можете отменить этот 
поиск и тем самым запретить внесение изменений (Рис. B.7).

Рис. B.6 - Опции автоматического создания классов и комнат

Рис. B.7 - Вкладка Comparator в опциях проекта
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На вкладке ECO Generation вы можете отключить вывод данных по изменениях в окне ECO. Если установить опцию 
Ignore Differences, то данные по соответствующему объекту не попадут в отчет ECO (Рис. B.8).

Конечно, количество изменений, которые вы можете увидеть при синхронизации проекта может быть различным. 
Некоторые ошибки можно устранить только вручную и затем попытаться еще раз передать данные. В итоге на экране 
должно появиться сообщение о том, что изменения не требуются. Более подробно о синхронизации проекта Altium 
Designer вы можете прочесть здесь.

Рис. B.8 - Вкладка ECO Generation в опциях проекта
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